summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-10-12 00:08:06 -0500
committerLuis Martinez2022-10-12 00:08:06 -0500
commit7bc707dc2ffcc06bf4be4c40f904eb3f46d0d6ec (patch)
treec424186e97be5ab762db74fff1bae954a39b1ada
parent7369e5d8add5f24293eac1d249078ec22073d1a0 (diff)
downloadaur-python-codetiming.tar.gz
update to 1.3.2
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md12
-rw-r--r--PKGBUILD4
3 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 571660b67fdd..5991609e2df2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-codetiming
pkgdesc = Flexible, customizable timer for your Python code
- pkgver = 1.3.1
+ pkgver = 1.3.2
pkgrel = 1
url = https://github.com/realpython/codetiming
changelog = CHANGELOG.md
@@ -11,7 +11,7 @@ pkgbase = python-codetiming
makedepends = python-build
makedepends = python-installer
depends = python
- source = python-codetiming-1.3.1.tar.gz::https://files.pythonhosted.org/packages/source/c/codetiming/codetiming-1.3.1.tar.gz
- sha256sums = 2fcb4afb18e0ac8302e4e059d2d3343ee1df0ab84d26ddf8cd80b9205c9e67dc
+ source = python-codetiming-1.3.2.tar.gz::https://files.pythonhosted.org/packages/source/c/codetiming/codetiming-1.3.2.tar.gz
+ sha256sums = f8a4ed71042a571e9863022573b76036d3efed726f2bb99a3536e56c201da49c
pkgname = python-codetiming
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 45934054989e..aab8eca0f8aa 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -7,6 +7,12 @@ The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
## [Unreleased]
+## [1.3.2] - 2022-10-07
+
+### Added
+
+- `__all__` to specify the public API (by [@alkatar21](https://github.com/alkatar21) in [#46])
+
## [1.3.1] - 2022-10-06
### Added
@@ -52,8 +58,9 @@ The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
Initial version of `codetiming`. Version 1.0.0 corresponds to the code in the tutorial [Python Timer Functions: Three Ways to Monitor Your Code](https://realpython.com/python-timer/).
-[Unreleased]: https://github.com/realpython/codetiming/compare/v1.3.1...HEAD
-[1.3.0]: https://github.com/realpython/codetiming/compare/v1.3.0...v1.3.1
+[Unreleased]: https://github.com/realpython/codetiming/compare/v1.3.2...HEAD
+[1.3.2]: https://github.com/realpython/codetiming/compare/v1.3.1...v1.3.2
+[1.3.1]: https://github.com/realpython/codetiming/compare/v1.3.0...v1.3.1
[1.3.0]: https://github.com/realpython/codetiming/compare/v1.2.0...v1.3.0
[1.2.0]: https://github.com/realpython/codetiming/compare/v1.1.0...v1.2.0
[1.1.0]: https://github.com/realpython/codetiming/compare/v1.0.0...v1.1.0
@@ -73,3 +80,4 @@ Initial version of `codetiming`. Version 1.0.0 corresponds to the code in the tu
[#34]: https://github.com/realpython/codetiming/pull/34
[#35]: https://github.com/realpython/codetiming/pull/35
[#38]: https://github.com/realpython/codetiming/pull/38
+[#46]: https://github.com/realpython/codetiming/pull/46
diff --git a/PKGBUILD b/PKGBUILD
index 474a5f253ab3..700235e6d8b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-codetiming
_pkg="${pkgname#python-}"
-pkgver=1.3.1
+pkgver=1.3.2
pkgrel=1
pkgdesc="Flexible, customizable timer for your Python code"
license=('MIT')
@@ -14,7 +14,7 @@ makedepends=('python-flit-core' 'python-build' 'python-installer')
checkdepends=('python-pytest')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/c/$_pkg/$_pkg-$pkgver.tar.gz")
-sha256sums=('2fcb4afb18e0ac8302e4e059d2d3343ee1df0ab84d26ddf8cd80b9205c9e67dc')
+sha256sums=('f8a4ed71042a571e9863022573b76036d3efed726f2bb99a3536e56c201da49c')
build() {
cd "$_pkg-$pkgver"