summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhirui Dai2024-04-28 14:57:18 -0700
committerZhirui Dai2024-04-28 14:57:18 -0700
commit8944df1994eaecd65ce80da5f9c39836802ce15e (patch)
tree93f4111c66dba50dd9c40706b29a5aa7ae21fec9
parentd50da057c737ca4954fc0cd3ecc9afa760cc94ba (diff)
downloadaur-python-colcon-test-result.tar.gz
remove check
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 3 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf86035c54ab..af88ff57187d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,13 +6,10 @@ pkgbase = python-colcon-test-result
arch = any
license = Apache
makedepends = python-setuptools
- makedepends = flake8
depends = python-colcon-core
source = https://github.com/colcon/colcon-test-result/archive/refs/tags/0.3.8.tar.gz
source = upstream.path::https://github.com/colcon/colcon-test-result/compare/0.3.8...master.patch
- source = https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz
sha256sums = b10643fd8de667e320843558aafbf7dd4f756b6addbbe7e03e08f5de6e375d06
sha256sums = 35986bb5ddcf824b113792504c273cceb25bc4c385e80d63fd810349775b531c
- sha256sums = 04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082
pkgname = python-colcon-test-result
diff --git a/PKGBUILD b/PKGBUILD
index 59d08f7fa017..4ac19bdb13cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,26 +9,18 @@ arch=(any)
url="https://pypi.org/project/colcon-test-result"
license=('Apache')
depends=('python-colcon-core')
-makedepends=('python-setuptools' 'flake8')
+makedepends=('python-setuptools')
source=(
https://github.com/colcon/colcon-test-result/archive/refs/tags/${pkgver}.tar.gz
- upstream.path::https://github.com/colcon/colcon-test-result/compare/0.3.8...master.patch
- https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz)
+ upstream.path::https://github.com/colcon/colcon-test-result/compare/0.3.8...master.patch)
sha256sums=('b10643fd8de667e320843558aafbf7dd4f756b6addbbe7e03e08f5de6e375d06'
- '35986bb5ddcf824b113792504c273cceb25bc4c385e80d63fd810349775b531c'
- '04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082')
+ '35986bb5ddcf824b113792504c273cceb25bc4c385e80d63fd810349775b531c')
build() {
cd ${srcdir}/${_name}-${pkgver}
python -m build --wheel --no-isolation
}
-check() {
- cd ${srcdir}/${_name}-${pkgver}
- export PYTHONPATH="${srcdir}/scspell-2.2"
- ls test*.py | xargs -I {} pytest {}
-}
-
package() {
cd ${srcdir}/${_name}-${pkgver}
python -m installer --destdir="${pkgdir}" dist/*.whl