summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThompson, Brian2024-06-22 21:05:36 -0500
committerThompson, Brian2024-06-22 21:05:36 -0500
commitb2311c05486a27fbf7fe3559205938057c4cea1e (patch)
treee8fe1a4111fc75ff5010644b782904be614b002c
downloadaur-python-conda-package-streaming.tar.gz
build: init release 0.10.0
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD60
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..761e4abe9bba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = python-conda-package-streaming
+ pkgdesc = An efficient library to read from new and old format .conda and .tar.bz2 conda packages
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/conda/conda-package-streaming
+ arch = x86_64
+ license = BSD-3-Clause
+ checkdepends = python-pytest
+ checkdepends = python-pytest-cov
+ checkdepends = python-pytest-mock
+ checkdepends = python-boto3
+ checkdepends = python-bottle
+ checkdepends = python-conda
+ checkdepends = python-conda-package-handling
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-flit-core
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ depends = python-requests
+ depends = python-zstandard
+ provides = python-conda-package-streaming
+ conflicts = python-conda-package-streaming
+ replaces = python-conda-package-streaming
+ source = conda-package-streaming-0.10.0.tar.gz::https://github.com/conda/conda-package-streaming/archive/refs/tags/v0.10.0.tar.gz
+ sha512sums = f4f1efb609a77a4c28e230e1c23b0ee65f682228643dc93bb4055edd3111e31f853f5af672bd551d09e219374589d110f349c3f4899c5f881cae25600ba0eceb
+
+pkgname = python-conda-package-streaming
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b63977a0ed66
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68ddd1d88ebc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Brian Thompson <brianrobt@pm.me>
+
+pkgname='python-conda-package-streaming'
+pkgver='0.10.0'
+pkgrel=1
+pkgdesc='An efficient library to read from new and old format .conda and .tar.bz2 conda packages'
+_srcname="conda-package-streaming-${pkgver}"
+arch=('x86_64')
+url='https://github.com/conda/conda-package-streaming'
+license=('BSD-3-Clause')
+depends=(
+ 'python'
+ 'python-requests'
+ 'python-zstandard'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-flit-core'
+ 'python-setuptools'
+ 'python-wheel'
+)
+checkdepends=(
+ 'python-pytest'
+ 'python-pytest-cov'
+ 'python-pytest-mock'
+ 'python-boto3'
+ 'python-bottle'
+ 'python-conda'
+ 'python-conda-package-handling'
+)
+provides=("${pkgname%}")
+conflicts=("${pkgname%}")
+replaces=("${pkgname%}")
+source=(
+ "${_srcname}.tar.gz::https://github.com/conda/conda-package-streaming/archive/refs/tags/v${pkgver}.tar.gz"
+)
+sha512sums=(
+ 'f4f1efb609a77a4c28e230e1c23b0ee65f682228643dc93bb4055edd3111e31f853f5af672bd551d09e219374589d110f349c3f4899c5f881cae25600ba0eceb'
+)
+
+build() {
+ cd "$srcdir/$_srcname"
+ python -m build --wheel --no-isolation
+}
+
+# TODO: Get unit tests working
+# check() {
+# local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+# cd "$srcdir/$_srcname"
+# python -m installer --destdir="test_dir" dist/*.whl
+# export PYTHONPATH="$PWD/test_dir/$site_packages:$PYTHONPATH"
+# pytest -vv
+# }
+
+package() {
+ cd "$srcdir/$_srcname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}