summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Wegner2021-02-08 10:07:22 +0100
committerFrederik Wegner2021-02-08 10:14:44 +0100
commit2b6ed15e146a6daafcc8e979bc2ece0a70bc38d9 (patch)
tree4d855461aa76198d3c31918715db0163a086804b
downloadaur-python-cpprb.tar.gz
Created package for python-cpprb.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c742e17f710
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-cpprb
+ pkgdesc = ReplayBuffer for Reinforcement Learning written by C++ and Cython
+ pkgver = v9.4.5
+ pkgrel = 1
+ url = https://ymd_h.gitlab.io/cpprb/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = cython>=0.29
+ depends = python>=3.5
+ depends = python-numpy
+ optdepends = python-matplotlib: needed for gym
+ optdepends = python-pyvirtualdisplay: needed for gym
+ optdepends = python-sphinx: needed for api
+ optdepends = python-sphinx-rtd-theme: needed for api
+ optdepends = python-sphinx-automodapi: needed for api
+ provides = python-cpprb
+ conflicts = python-cpprb
+ source = https://gitlab.com/ymd_h/cpprb/-/archive/v9.4.5/cpprb-v9.4.5.tar.gz
+ sha256sums = SKIP
+
+pkgname = python-cpprb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52a5eabe5bcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer : Frederik Wegner <wegnerfrederik at gmail dot com>
+_name="cpprb"
+pkgname=python-cpprb
+pkgver=v9.4.5
+pkgrel=1
+pkgdesc="ReplayBuffer for Reinforcement Learning written by C++ and Cython"
+arch=('any')
+url="https://ymd_h.gitlab.io/cpprb/"
+license=('MIT')
+depends=('python>=3.5' 'python-numpy')
+optdepends=(
+ 'python-matplotlib: needed for gym'
+ 'python-pyvirtualdisplay: needed for gym'
+ 'python-sphinx: needed for api'
+ 'python-sphinx-rtd-theme: needed for api'
+ 'python-sphinx-automodapi: needed for api'
+ )
+provides=("python-$_name")
+conflicts=("python-$_name")
+makedepends=(
+ 'python-setuptools'
+ 'cython>=0.29'
+ )
+source=("https://gitlab.com/ymd_h/$_name/-/archive/$pkgver/$_name-$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+pkgver() {
+ git ls-remote --tags --sort='v:refname' https://gitlab.com/ymd_h/cpprb \
+ | tail --lines=1 \
+ | cut --delimiter='/' --fields=3
+}
+
+package() {
+ cd ${srcdir}/$_name-$pkgver
+ install -D -m644 LICENSE "${pkgdir}/usr/share/license/${pkgname}/LICENSE"
+ python setup.py install --optimize=1 --root="$pkgdir"
+}