summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32023-12-11 09:40:21 +0100
committergilcu32023-12-11 09:40:21 +0100
commit9403e177127066dfda0f38be5fe3a4036c79a401 (patch)
tree490158e268adcb6bfd5fdb0d86263f34e72096f5
parent039ed4b53a2f7276f5375c201f070cf88eecd3df (diff)
downloadaur-python-ctranslate2-bin.tar.gz
follow python guidelines, thanks @yochananmarqos
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee0b3ad66314..f7109cfe4f63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python-ctranslate2-bin
pkgdesc = CTranslate2 is a C++ and Python library for efficient inference with Transformer models.
pkgver = 3.23.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/OpenNMT/CTranslate2
arch = x86_64
license = MIT
- makedepends = python-pip
- depends = python>=3.7
+ depends = gcc-libs
depends = python-numpy
+ depends = python-pytorch
+ depends = python-setuptools
depends = python-yaml
provides = ctranslate2
conflicts = ctranslate2-git
diff --git a/PKGBUILD b/PKGBUILD
index 53ba99b47b09..edb5d6e1aa16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,19 @@
_pkgname=ctranslate2
pkgname=python-$_pkgname-bin
pkgver=3.23.0
-pkgrel=1
+pkgrel=2
pkgdesc="CTranslate2 is a C++ and Python library for efficient inference with Transformer models."
arch=('x86_64')
url="https://github.com/OpenNMT/CTranslate2"
license=('MIT')
provides=("ctranslate2")
conflicts=('ctranslate2-git' 'python-ctranslate2-git')
-depends=('python>=3.7' 'python-numpy' 'python-yaml')
-makedepends=('python-pip')
+depends=('gcc-libs' 'python-numpy' 'python-pytorch' 'python-setuptools' 'python-yaml')
_py=cp311
wheel_name=${_pkgname//-/_}-$pkgver-$_py-${_py}-manylinux_2_17_$arch.manylinux2014_$arch.whl
source=(https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/$_pkgname/$wheel_name)
sha256sums=('cf8a0d3085297373208f6e703e096bfd3b19ec80bf133e006fdcd7e88996b11b')
package() {
- pip install --isolated --upgrade --no-deps --ignore-installed --root=$pkgdir --no-warn-script-location $wheel_name
- python -m compileall -d /usr "$pkgdir"/usr
- python -O -m compileall -d /usr "$pkgdir"/usr
+ python -m installer --destdir="$pkgdir" $wheel_name
}