summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2022-01-26 19:37:01 +1100
committerMatthew Gamble2022-01-26 19:37:15 +1100
commitce1f71a4c90d4177716da1d64f113ec44c0af837 (patch)
tree705a0dbec43129aa048f28a95d33adc90b7eb3d3
parent17c8a752a068292aa57fa133c8e14acf4c8e986f (diff)
downloadaur-python-cuddle.tar.gz
Update to latest release. Actually make packaging functional.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 27 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c67ecf7f5170..565f3d541346 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = python-cuddle
pkgdesc = Python implementation of the KDL Document Language
- pkgver = 1.0.3
- pkgrel = 2
+ pkgver = 1.0.6
+ pkgrel = 1
url = https://github.com/djmattyg007/python-cuddle
arch = any
license = MIT
+ checkdepends = python-invoke
+ checkdepends = python-pytest
makedepends = python-poetry-core
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-install
depends = python
depends = python-regex
depends = python-tatsu
- source = https://pypi.io/packages/source/c/cuddle/cuddle-1.0.3.tar.gz
- sha256sums = a5d7066544c8d7d5025436482113a4b03c0595772b9796b393a6414eece716a1
+ source = https://github.com/djmattyg007/python-cuddle/archive/1.0.6.tar.gz
+ sha256sums = 05cc62128198af7c20aa228786de5ebd1402d07d5c7225bdcd2eaf2998ec5e22
pkgname = python-cuddle
diff --git a/PKGBUILD b/PKGBUILD
index 3c2b6b8bcc5e..ccaee7867585 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,37 @@
# Maintainer: Matthew Gamble <git@matthewgamble.net>
pkgname=python-cuddle
-pkgver=1.0.3
-pkgrel=2
+pkgver=1.0.6
+pkgrel=1
pkgdesc="Python implementation of the KDL Document Language"
arch=("any")
url="https://github.com/djmattyg007/python-cuddle"
license=("MIT")
depends=("python" "python-regex" "python-tatsu")
-makedepends=("python-poetry-core" "python-setuptools")
-source=("https://pypi.io/packages/source/c/cuddle/cuddle-${pkgver}.tar.gz")
-sha256sums=("a5d7066544c8d7d5025436482113a4b03c0595772b9796b393a6414eece716a1")
+checkdepends=("python-invoke" "python-pytest")
+makedepends=("python-poetry-core" "python-build" "python-install")
+source=("https://github.com/djmattyg007/python-cuddle/archive/${pkgver}.tar.gz")
+sha256sums=("05cc62128198af7c20aa228786de5ebd1402d07d5c7225bdcd2eaf2998ec5e22")
build() {
- cd "cuddle-${pkgver}"
+ cd "python-cuddle-${pkgver}"
- python setup.py build
+ python -m build --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd "python-cuddle-${pkgver}"
+
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m install --optimize=1 dist/*.whl
+ PACKAGING=true test-env/bin/python -m invoke test
}
package() {
- cd "cuddle-${pkgver}"
+ cd "python-cuddle-${pkgver}"
+
+ python -m install --destdir="${pkgdir}" --optimize=1 dist/*.whl
- PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-cuddle/LICENSE.txt"
install -Dm644 README.md "${pkgdir}/usr/share/doc/python-cuddle/README.md"
install -Dm644 CHANGELOG.md "${pkgdir}/usr/share/doc/python-cuddle/CHANGELOG.md"