summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuncan X. Simpson2019-09-27 22:47:30 -0700
committerDuncan X. Simpson2019-09-27 22:47:30 -0700
commita2010f44c07786847da8a70f1008ef5e0b74ffbd (patch)
tree791a33c34590cd269e2d024b60f0cdb3920cb922
downloadaur-python-deadsimplekv.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a020340fb5ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-deadsimplekv
+ pkgdesc = A simple key-value store with caching for Python
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/beardog108/deadsimplekv
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/2f/3e/183d7f11d2fda4c5fb3f3cfd5a13452e1de499f5666b9345750d9325201a/deadsimplekv-0.2.0.tar.gz
+ md5sums = a1975f53658fd53af1522f0e84cccd8e
+
+pkgname = python-deadsimplekv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf09c6341617
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Duncan X Simpson <duncan@k7dxs.net>
+
+pkgname=python-deadsimplekv
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A simple key-value store with caching for Python"
+arch=('any')
+depends=('python')
+makedepends=('python-setuptools')
+url="https://github.com/beardog108/deadsimplekv"
+license=('GPL3')
+source=("https://files.pythonhosted.org/packages/2f/3e/183d7f11d2fda4c5fb3f3cfd5a13452e1de499f5666b9345750d9325201a/deadsimplekv-0.2.0.tar.gz")
+md5sums=('a1975f53658fd53af1522f0e84cccd8e')
+
+build() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ msg2 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ msg2 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+}