summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-08-01 10:39:55 +0200
committerAntonio Rojas2022-08-01 10:39:55 +0200
commit5f20d569358723f6deb28db51677b2a4a5562b6e (patch)
tree67ea3036e79bde390af7afd80094930515630d51
downloadaur-python-dephell-archive.tar.gz
import from community
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5985d94d053f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-dephell-archive
+ pkgdesc = Pathlib for archives
+ pkgver = 0.1.7
+ pkgrel = 2
+ url = https://github.com/dephell/dephell-archive
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python-attrs
+ source = https://files.pythonhosted.org/packages/source/d/dephell-archive/dephell-archive-0.1.7.tar.gz
+ sha256sums = bb263492a7d430f9e04cef9a0237b7752cc797ab364bf35e70196af09c73ea37
+ b2sums = c07e703fd177072a29bc45b70b15273d23d889ab2a0de9434b30ac272c46c648e7214f5d8aaab136f868e0dadfbd290279b160dfd7183603cfcebf3b5bea435c
+
+pkgname = python-dephell-archive
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97ed32cdbb79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Eli Schwartz <eschwartz@archlinux.org>
+
+_pkgname=dephell-archive
+pkgname=python-dephell-archive
+pkgver=0.1.7
+pkgrel=2
+pkgdesc="Pathlib for archives"
+arch=('any')
+url="https://github.com/dephell/${_pkgname}"
+license=('MIT')
+depends=('python-attrs')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('bb263492a7d430f9e04cef9a0237b7752cc797ab364bf35e70196af09c73ea37')
+b2sums=('c07e703fd177072a29bc45b70b15273d23d889ab2a0de9434b30ac272c46c648e7214f5d8aaab136f868e0dadfbd290279b160dfd7183603cfcebf3b5bea435c')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+
+ # pycache slipped into release tarballs
+ find . -name \*.pyc -delete
+}
+
+build(){
+ cd ${_pkgname}-${pkgver}
+
+ python setup.py build
+}
+
+check() {
+ cd ${_pkgname}-${pkgver}
+
+ python setup.py test
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}