summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-10-23 16:59:55 +0200
committerMichal Wojdyla2021-10-23 16:59:55 +0200
commit0273ac5575e3fb5f45ade77dbf4efcf5ed2ec08a (patch)
tree788530ba864738b71e81f7aeda34a0f82fef6d4e
parent10331971b59e9808d32c8cc9a3efb620bb67de36 (diff)
downloadaur-python-detectron2-git.tar.gz
update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dadc4e76d92..9eaee53460d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
pkgbase = python-detectron2-git
pkgdesc = Detectron2 is Facebook AI Research's next generation software system that implements state-of-the-art object detection algorithms.
- pkgver = r304.5e2a1ec
+ pkgver = 0.5.r85.ga24729ab
pkgrel = 1
url = https://github.com/facebookresearch/detectron2
- arch = any
+ arch = x86_64
license = Apache-2.0
- depends = python
- depends = python-setuptools
- depends = python-pytorch
+ makedepends = git
+ makedepends = python-setuptools
depends = python-torchvision
depends = python-cocoapi
- optdepends = opencv
provides = python-detectron2
conflicts = python-detectron2
source = detectron2::git+https://github.com/facebookresearch/detectron2.git
sha256sums = SKIP
pkgname = python-detectron2-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 42017bb11eb9..c26c86214d7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
-# Maintainer: jerry73204 <jerry73204@gmail.com>
+# Contributor: jerry73204 <jerry73204@gmail.com>
pkgname='python-detectron2-git'
_reponame='detectron2'
-pkgver='r304.5e2a1ec'
-pkgrel='1'
+pkgver=0.5.r85.ga24729ab
+pkgrel=1
pkgdesc="Detectron2 is Facebook AI Research's next generation software system that implements state-of-the-art object detection algorithms."
-arch=('any')
+arch=('x86_64')
url='https://github.com/facebookresearch/detectron2'
license=('Apache-2.0')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
-depends=(
- 'python'
- 'python-setuptools'
- 'python-pytorch'
- 'python-torchvision'
- 'python-cocoapi'
-)
-optdepends=('opencv')
+depends=('python-torchvision' 'python-cocoapi')
+makedepends=('git' 'python-setuptools')
source=("${_reponame}::git+https://github.com/facebookresearch/detectron2.git")
sha256sums=('SKIP')
-pkgber() {
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -30,9 +25,8 @@ build() {
python setup.py build
}
-
package() {
cd "${srcdir}/${_reponame}"
- python setup.py install --root="${pkgdir}"/ --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
}