summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-12 13:23:52 -0500
committerCarlos Aznarán Laos2022-01-12 13:23:52 -0500
commitdcf360974d3e77ccfb43d10e0bcc46ed8a93a161 (patch)
tree1cea6cc7c5fb9a6cbfdcd924efeccc14e94756de
parentdea8b8a07c8ebb610c29a10a607aea61193ba502 (diff)
downloadaur-python-django-cms.tar.gz
Version bump to 3.9.0
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD36
3 files changed, 24 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63f43e523763..61526c4d4d3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,17 @@
pkgbase = python-django-cms
pkgdesc = An Advanced Django CMS
- pkgver = 3.7.4
+ pkgver = 3.9.0
pkgrel = 1
url = https://django-cms.org
arch = any
- license = BSD
- makedepends = python-django
- makedepends = python-django-classy-tags
- makedepends = python-django-formtools
- makedepends = python-treebeard
- makedepends = python-django-sekizai
- makedepends = python-djangocms-admin-style
- source = python-django-cms-3.7.4.tar.gz::https://github.com/divio/django-cms/archive/3.7.4.tar.gz
- sha256sums = de456b7ef2a3ddd2c7d923df89f42c8b564af1dd1ec5b28340294db2adca63b6
-
-pkgname = python-django-cms
- depends = python-django
+ license = custom
+ makedepends = python-setuptools
depends = python-django-classy-tags
depends = python-django-formtools
depends = python-treebeard
depends = python-django-sekizai
depends = python-djangocms-admin-style
+ source = https://github.com/django-cms/django-cms/archive/3.9.0.tar.gz
+ sha512sums = f5241eaa824ea7eb31b678bbd59c2fa7097fcff2f69c15bbf3660dce1bfa2ab43d891025edb4d2f135e9218fbbd1435811f250ea6db04168336e1fe0474c9db1
+pkgname = python-django-cms
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 3e36bbfbd5a2..d476465fd60e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,25 @@
-# Maintainer: Felix Golatofski <contact@xdfr.de>
-
-_name="django-cms"
-pkgbase="python-django-cms"
-pkgname=("python-django-cms")
-pkgver=3.7.4
+# Contributor: Felix Golatofski <contact@xdfr.de>
+_base=django-cms
+pkgname=python-${_base}
+pkgver=3.9.0
pkgrel=1
pkgdesc="An Advanced Django CMS"
-url="https://django-cms.org"
+url="https://${_base}.org"
arch=('any')
-license=('BSD')
-makedepends=("python-django" "python-django-classy-tags" "python-django-formtools" "python-treebeard" "python-django-sekizai" "python-djangocms-admin-style")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/divio/django-cms/archive/$pkgver.tar.gz")
-sha256sums=('de456b7ef2a3ddd2c7d923df89f42c8b564af1dd1ec5b28340294db2adca63b6')
-
+license=('custom')
+depends=(python-django-classy-tags python-django-formtools python-treebeard python-django-sekizai python-djangocms-admin-style)
+makedepends=(python-setuptools)
+source=(https://github.com/${_base}/${_base}/archive/${pkgver}.tar.gz)
+sha512sums=('f5241eaa824ea7eb31b678bbd59c2fa7097fcff2f69c15bbf3660dce1bfa2ab43d891025edb4d2f135e9218fbbd1435811f250ea6db04168336e1fe0474c9db1')
build() {
- cd $_name-$pkgver
- python setup.py build
+ cd "${_base}-${pkgver}"
+ python setup.py build
}
-package_python-django-cms() {
- depends=("python-django" "python-django-classy-tags" "python-django-formtools" "python-treebeard" "python-django-sekizai" "python-djangocms-admin-style")
-
- cd $_name-$pkgver
- python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+package() {
+ cd "${_base}-${pkgver}"
+ export PYTHONHASHSEED=0
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}