summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-03-07 14:02:47 +0100
committerPhilipp A2019-03-07 14:02:47 +0100
commit61351f39abe525c1902c3df2e75cbfba048fb37c (patch)
tree49d8eb32efe7c258b52c4d97519b232e88931e53
parentedbfe81e0025820fc958b27079cdfaffdce1b5d5 (diff)
downloadaur-python-docutils-stubs.tar.gz
v0.21
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c731f9d21deb..e5d3dc50230c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python-docutils-stubs
pkgdesc = PEP 561 type stubs for docutils
- pkgver = 0.0.19
+ pkgver = 0.0.21
pkgrel = 1
url = https://github.com/tk0miya/docutils-stubs
arch = any
- makedepends = python-pip
depends = python
- noextract = docutils_stubs-0.0.19-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py3/d/docutils-stubs/docutils_stubs-0.0.19-py3-none-any.whl
- sha256sums = ce16686c7a260a39cd0a33a50590fddd4f587ef7e3cdbf27dca4f2da12b45ab1
+ noextract = docutils_stubs-0.0.21-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/d/docutils-stubs/docutils_stubs-0.0.21-py3-none-any.whl
+ sha256sums = d8beb6ffac94d2db39179681f6bc17a3b81d3386201dc8b1aec3d61201b1edc9
pkgname = python-docutils-stubs
diff --git a/PKGBUILD b/PKGBUILD
index 82083e8ea036..257383ada26d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,21 @@
_name=docutils-stubs
pkgname=python-$_name
-pkgver=0.0.19
+pkgver=0.0.21
pkgrel=1
pkgdesc='PEP 561 type stubs for docutils'
arch=(any)
url="https://github.com/tk0miya/$_name"
license=()
depends=(python)
-makedepends=(python-pip)
-_wheel="${_name/-/_}-$pkgver-py3-none-any.whl"
-source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
-sha256sums=('ce16686c7a260a39cd0a33a50590fddd4f587ef7e3cdbf27dca4f2da12b45ab1')
+_pyarch=py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('d8beb6ffac94d2db39179681f6bc17a3b81d3386201dc8b1aec3d61201b1edc9')
noextract=("$_wheel")
package() {
- cd "$srcdir"
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}