summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDringsim2023-08-26 21:12:25 +0800
committerDringsim2023-08-26 21:12:25 +0800
commitd6aa89441becbbbcbe356c500024f55aa6d42e36 (patch)
treedd7a2aa12867a4552322fdecc1036842ad37351b
downloadaur-python-dot-kernel.tar.gz
create package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b5e0dcec03b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-dot-kernel
+ pkgdesc = Writing dot language and render in jupyter
+ pkgver = 0.1.8
+ pkgrel = 1
+ url = https://github.com/laixintao/jupyter-dot-kernel
+ arch = any
+ license = unknown
+ depends = python-graphviz
+ depends = python-jupyter-client
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/d/dot_kernel/dot_kernel-0.1.8.tar.gz
+ source = https://github.com/laixintao/jupyter-dot-kernel/raw/master/readme.md
+ sha256sums = 6bf5910b24e1068458ca181257e0a169fa19baf54965e61df9ba1cbb729dbdbf
+ sha256sums = 7347BDEAD32D46FC357B352958A4CCCAD4DD025856233F6032BDDD3096079DC1
+
+pkgname = python-dot-kernel
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22b06600e3d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Dringsim <dringsim@qq.com>
+
+pkgname=python-dot-kernel
+_name=dot_kernel
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="Writing dot language and render in jupyter"
+arch=('any')
+url="https://github.com/laixintao/jupyter-dot-kernel"
+license=('unknown')
+makedepends=()
+depends=('python-graphviz' 'python-jupyter-client' 'python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ 'https://github.com/laixintao/jupyter-dot-kernel/raw/master/readme.md')
+sha256sums=('6bf5910b24e1068458ca181257e0a169fa19baf54965e61df9ba1cbb729dbdbf'
+ '7347BDEAD32D46FC357B352958A4CCCAD4DD025856233F6032BDDD3096079DC1')
+
+build() {
+ cp readme.md "$_name-$pkgver"
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}