summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomas Krizek2019-08-07 13:44:43 +0200
committerTomas Krizek2019-08-07 13:47:14 +0200
commitbb7ed9d8863472b6e5fcd08df2d943b5d3d7c6d1 (patch)
treee88cedb88cd3f147b699c12adb272e3b9e4a16b8
downloadaur-python-dpkt-git.tar.gz
initial package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6681b655ef27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-dpkt-git
+ pkgdesc = This is a Python library for interacting with and creating packets.
+ pkgver = v1.9.2.r33.2c6aada
+ pkgrel = 1
+ url = https://github.com/kbandla/dpkt
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ provides = python-dpkt
+ conflicts = python-dpkt
+ source = dpkt::git+https://github.com/kbandla/dpkt.git
+ md5sums = SKIP
+
+pkgname = python-dpkt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09aa54aa6d0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tomas Krizek <tomas.krizek@nic.cz>
+pkgname=python-dpkt-git
+_pkgname=dpkt
+pkgver=v1.9.2.r33.2c6aada
+pkgrel=1
+pkgdesc="This is a Python library for interacting with and creating packets."
+arch=('any')
+url="https://github.com/kbandla/dpkt"
+license=('BSD')
+depends=('python')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('dpkt::git+https://github.com/kbandla/dpkt.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="${pkgdir}"
+}