summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2023-09-04 18:53:26 +0200
committerMarco Rubin2023-09-04 18:53:26 +0200
commit68e7ce21159997abf2a62580cad7025dad0258ae (patch)
treeba18b433fab0bc064424de7ce355b6391831eaeb
parent00512912cb5371c537997cd924965faa615d830c (diff)
downloadaur-python-easyocr.tar.gz
restore check, new build process
-rwxr-xr-x.SRCINFO20
-rwxr-xr-xPKGBUILD20
2 files changed, 29 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29f39bb8ba5d..be264eae909c 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,29 @@
pkgbase = python-easyocr
pkgdesc = End-to-End Multi-Lingual Optical Character Recognition (OCR) Solution
pkgver = 1.7.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/JaidedAI/EasyOCR
arch = any
license = Apache
+ checkdepends = hdf5
+ checkdepends = ninja
+ checkdepends = python
+ checkdepends = python-bidi
+ checkdepends = python-numpy
+ checkdepends = python-opencv
+ checkdepends = python-torchvision>=0.5
+ checkdepends = python-pillow
+ checkdepends = python-pyaml
+ checkdepends = python-pyclipper
+ checkdepends = python-pytorch
+ checkdepends = python-scikit-image
+ checkdepends = python-scipy
+ checkdepends = python-shapely
+ checkdepends = python-pytorch-cuda
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = hdf5
depends = ninja
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 60a67e78da22..56a07b49c3df 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_name=EasyOCR
pkgname=python-easyocr
pkgver=1.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="End-to-End Multi-Lingual Optical Character Recognition (OCR) Solution"
arch=("any")
url="https://github.com/JaidedAI/EasyOCR"
@@ -25,8 +25,8 @@ depends=(
'python-scipy'
'python-shapely'
)
-makedepends=('python-setuptools')
-# checkdepends=(${depends[*]} 'python-pytorch-cuda')
+makedepends=(python-build python-installer python-setuptools python-wheel)
+checkdepends=(${depends[*]} 'python-pytorch-cuda')
conflicts=("$pkgname-git")
replaces=("$pkgname-git")
source=("$url/archive/v$pkgver.tar.gz")
@@ -34,19 +34,19 @@ b2sums=('8d56d59f020c501f1aeaa5876968747ca4b9e648f5510121aa180705b05b3efa3690932
build() {
cd $_name-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd $_name-$pkgver
- # python unit_test/run_unit_test.py \
- # --easyocr ./easyocr \
- # --verbose 2 \
- # --test_data unit_test/data/EasyOcrUnitTestPackage.pickle \
- # --image_data_dir ./examples
+ python unit_test/run_unit_test.py \
+ --easyocr ./easyocr \
+ --verbose 2 \
+ --test_data unit_test/data/EasyOcrUnitTestPackage.pickle \
+ --image_data_dir ./examples
}
package() {
cd $_name-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}