summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-09-26 12:38:58 -0500
committerLuis Martinez2022-09-26 12:38:58 -0500
commit59f96ea9a2a5b67965efaa998e367a8570311903 (patch)
treebc8a2a93b2a04fbaffd93acf30da4776b992e47b
parent3cb76269c22999d3d42977d888f8f212c7649e41 (diff)
downloadaur-python-enaml.tar.gz
update to 0.15.2
-rw-r--r--.SRCINFO27
-rw-r--r--LICENSE96
-rw-r--r--PKGBUILD166
-rw-r--r--PKGBUILD_EXTRAS0
4 files changed, 55 insertions, 234 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7b161ac2d49..c073ab776c77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,28 @@
pkgbase = python-enaml
pkgdesc = Declarative DSL for building rich user interfaces in Python
- pkgver = 0.12.0
- pkgrel = 00
+ pkgver = 0.15.2
+ pkgrel = 1
url = https://github.com/nucleic/enaml
arch = x86_64
license = BSD
- makedepends = python-pip
+ checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-cppy
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-setuptools-scm
+ makedepends = python-sphinx
makedepends = python-wheel
- depends = python
+ depends = python>=3.8
depends = python-ply
depends = python-atom
depends = python-bytecode
depends = python-kiwisolver
- source = PKGBUILD_EXTRAS
- source = https://files.pythonhosted.org/packages/d5/d5/b3e88ac554ea36b77d08b612e3259d998ad9868ac60f3c60918377c9999f/enaml-0.12.0.tar.gz
- source = LICENSE
- md5sums = SKIP
- md5sums = 8e77a894b8546ee8a4678dfb3aad25a3
- md5sums = 9498cbdb4d81d88314d3baca05dcbe5f
+ optdepends = python-pyqt5
+ optdepends = pyside2
+ optdepends = python-pyqt6
+ optdepends = pyside6
+ source = python-enaml-0.15.2.tar.gz::https://files.pythonhosted.org/packages/source/e/enaml/enaml-0.15.2.tar.gz
+ sha256sums = 75ba5b120fe1a90418ff03103acdc6a25d1b044dc4e42bcc42cb7f2e76f6d95b
pkgname = python-enaml
-
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index ed5e03afced4..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,96 +0,0 @@
-==========================
- The Enaml licensing terms
-==========================
-Enaml is licensed under the terms of the Modified BSD License (also known as
-New or Revised BSD), as follows:
-
-Copyright (c) 2013, Nucleic Development Team
-Copyright (c) 2013, Enthought, Inc.
-
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
-Redistributions of source code must retain the above copyright notice, this
-list of conditions and the following disclaimer.
-
-Redistributions in binary form must reproduce the above copyright notice, this
-list of conditions and the following disclaimer in the documentation and/or
-other materials provided with the distribution.
-
-Neither the name of the Nucleic Development Team nor the names of its
-contributors may be used to endorse or promote products derived from this
-software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE
-FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-About Enaml
------------
-Chris Colbert began the Enaml project under the umbrella of Enthought, Inc.
-in August 2011. The project was forked into the Nucleic project in March
-2013. Chris is still the project lead.
-
-The Nucleic Development Team is the set of all contributors to the Nucleic
-project and its subprojects.
-
-The core team that coordinates development on GitHub can be found here:
-http://github.com/nucleic. The current team consists of:
-
-* Chris Colbert
-* Matthieu Dartiailh
-
-Previous contributors include:
-
-* Ioannis Tziakos
-* Robert Kern
-* Corran Webster
-* David Wyde
-* Brett Patterson
-* Tim Diller
-* John Wiggins
-* Didrik Pinte
-* Deepankar Sharma
-* Kelsey Jordahl
-* Naveen Michaud-Agrawal
-* Steven Silvester
-* Mark Dickinson
-* Simon Jagoe
-* Chris Farrow
-* Puneeth Chaganti
-* Matthew Scott
-* Jack Minardi
-* Warren Weckesser
-* Christoph Gohlke
-
-Our Copyright Policy
---------------------
-Nucleic uses a shared copyright model. Each contributor maintains copyright
-over their contributions to Nucleic. But, it is important to note that these
-contributions are typically only changes to the repositories. Thus, the Nucleic
-source code, in its entirety is not the copyright of any single person or
-institution. Instead, it is the collective copyright of the entire Nucleic
-Development Team. If individual contributors want to maintain a record of what
-changes/contributions they have specific copyright on, they should indicate
-their copyright in the commit message of the change, when they commit the
-change to one of the Nucleic repositories.
-
-With this in mind, the following banner should be used in any source code file
-to indicate the copyright and license terms:
-
-#------------------------------------------------------------------------------
-# Copyright (c) 2013-2019, Nucleic Development Team.
-#
-# Distributed under the terms of the Modified BSD License.
-#
-# The full license is in the file LICENSE, distributed with this software.
-#------------------------------------------------------------------------------
diff --git a/PKGBUILD b/PKGBUILD
index 8fe77337480c..2018e75eb1c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,138 +1,50 @@
-# Maintainer: Unknown Packager
-
-export PIP_CONFIG_FILE=/dev/null
-export PIP_DISABLE_PIP_VERSION_CHECK=true
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=python-enaml
-epoch=
-pkgver=0.12.0
-pkgrel=00
+_pkg=enaml
+pkgver=0.15.2
+pkgrel=1
pkgdesc='Declarative DSL for building rich user interfaces in Python'
-arch=(x86_64)
+arch=('x86_64')
url=https://github.com/nucleic/enaml
-license=(BSD)
-depends=(python python-ply python-atom python-bytecode python-kiwisolver)
-depends+=()
-makedepends=(python-pip python-wheel)
-checkdepends=()
-provides=()
-conflicts=(${provides%=*}) # No quotes, to avoid an empty entry.
-source=(PKGBUILD_EXTRAS)
-md5sums=(SKIP)
-noextract=()
-source+=(https://files.pythonhosted.org/packages/d5/d5/b3e88ac554ea36b77d08b612e3259d998ad9868ac60f3c60918377c9999f/enaml-0.12.0.tar.gz)
-md5sums+=(8e77a894b8546ee8a4678dfb3aad25a3)
-source+=(LICENSE)
-md5sums+=(9498cbdb4d81d88314d3baca05dcbe5f)
-
-_first_source() {
- echo " ${source_i686[@]} ${source_x86_64[@]} ${source[@]}" |
- tr ' ' '\n' | grep -Pv '^(PKGBUILD_EXTRAS)?$' | head -1
-}
-
-_vcs="$(grep -Po '^[a-z]+(?=\+)' <<< "$(_first_source)")"
-if [[ "$_vcs" ]]; then
- makedepends+=("$(pkgfile --quiet /usr/bin/$_vcs)")
- provides+=("${pkgname%-$_vcs}")
- conflicts+=("${pkgname%-$_vcs}")
-fi
-
-_is_wheel() {
- [[ $(_first_source) =~ \.whl$ ]]
-}
-
-if [[ _is_wheel &&
- $(basename "$(_first_source)" | rev | cut -d- -f1 | rev) =~ ^manylinux ]]; then
- options=(!strip) # https://github.com/pypa/manylinux/issues/119
-fi
-
-_dist_name() {
- find "$srcdir" -mindepth 1 -maxdepth 1 -type d -printf '%f
-' |
- grep -v '^_tmpenv$'
+license=('BSD')
+depends=('python>=3.8' 'python-ply' 'python-atom' 'python-bytecode' 'python-kiwisolver')
+makedepends=(
+ 'python-build'
+ 'python-cppy'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-setuptools-scm'
+ 'python-sphinx'
+ 'python-wheel')
+optdepends=('python-pyqt5' 'pyside2' 'python-pyqt6' 'pyside6')
+checkdepends=('python-pytest')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/e/$_pkg/$_pkg-$pkgver.tar.gz")
+sha256sums=('75ba5b120fe1a90418ff03103acdc6a25d1b044dc4e42bcc42cb7f2e76f6d95b')
+
+prepare() {
+ cd "$_pkg-$pkgver"
+ sed -i '/sphinx.ext.graphviz/d;152d' docs/source/conf.py
}
-if [[ $(_first_source) =~ ^git+ ]]; then
- _pkgver() {
- ( set -o pipefail
- cd "$srcdir/$(_dist_name)"
- git describe --long --tags 2>/dev/null |
- sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" \
- "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
- }
-
- pkgver() { _pkgver; }
-fi
-
-_build() {
- if _is_wheel; then return; fi
- cd "$srcdir"
- # See Arch Wiki/PKGBUILD/license.
- # Get the first filename that matches.
- local test_name
- if [[ ${license[0]} =~ ^(BSD|MIT|ZLIB|Python)$ ]]; then
- for test_name in LICENSE LICENSE.txt license.txt COPYING COPYING.md COPYING.rst COPYING.txt COPYRIGHT; do
- if cp "$srcdir/$(_dist_name)/$test_name" "$srcdir/LICENSE" 2>/dev/null; then
- break
- fi
- done
- fi
- # Use the latest version of pip, as Arch's version is historically out of
- # date(!) and newer versions do fix bugs (sometimes).
- python -mvenv --clear --system-site-packages _tmpenv
- _tmpenv/bin/pip --quiet install -U pip
- # Build the wheel (which we allow to fail) only after fetching the license.
- # In order to isolate from ~/.pydistutils.cfg, we need to set $HOME to a
- # temporary directory, and thus first $XDG_CACHE_HOME back to its real
- # location, so that pip inserts the wheel in the wheel cache. We cannot
- # use --global-option=--no-user-cfg instead because that fully disables
- # wheels, causing a from-source build of build dependencies such as
- # numpy/scipy.
- XDG_CACHE_HOME="${XDG_CACHE_HOME:-"$HOME/.cache"}" HOME=_tmpenv \
- _tmpenv/bin/pip wheel -v --no-deps --wheel-dir="$srcdir" \
- "./$(_dist_name)" || true
+build() {
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
+ local python_version="$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')"
+ PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-$python_version" make -C docs man
}
-build() { _build; }
-
-_check() {
- # Define check(), possibly using _check as a helper, to run the tests.
- # You may need to call `python setup.py build_ext -i` first.
- if _is_wheel; then return; fi
- cd "$srcdir/$(_dist_name)"
- /usr/bin/python setup.py -q test
+check() {
+ cd "$_pkg-$pkgver"
+ local python_version="$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')"
+ PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-$python_version" pytest -x
}
-_package() {
- cd "$srcdir"
- # pypa/pip#3063: pip always checks for a globally installed version.
- python -mvenv --clear --system-site-packages _tmpenv
- _tmpenv/bin/pip install --prefix="$pkgdir/usr" \
- --no-deps --ignore-installed --no-warn-script-location \
- "$(ls ./*.whl 2>/dev/null || echo ./"$(_dist_name)")"
- if [[ -d "$pkgdir/usr/bin" ]]; then # Fix entry points.
- for f in "$pkgdir/usr/bin/"*; do
- if [[ $(head -n1 "$f") = "#!$(readlink -f _tmpenv)/bin/python" ]]; then
- sed -i '1c#!/usr/bin/python' "$f"
- fi
- done
- fi
- if [[ -d "$pkgdir/usr/etc" ]]; then
- mv "$pkgdir/usr/etc" "$pkgdir/etc"
- fi
- if [[ -f LICENSE ]]; then
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- fi
+package() {
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 docs/build/man/enaml.1 -t "$pkgdir/usr/share/man/man1/"
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s "$_site/$_pkg-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
}
-
-package() { _package; }
-
-. "$(dirname "$BASH_SOURCE")/PKGBUILD_EXTRAS"
-
-# Remove makedepends already in depends (which may have been listed for the
-# first build, but autodetected on the second.
-makedepends=($(printf '%s\n' "${makedepends[@]}" |
- grep -Pwv "^($(IFS='|'; echo "${depends[*]}"))$"))
-: # Apparently ending with makedepends assignment sometimes fails.
diff --git a/PKGBUILD_EXTRAS b/PKGBUILD_EXTRAS
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/PKGBUILD_EXTRAS
+++ /dev/null