summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreDgar2021-08-31 15:16:57 -0500
committereDgar2021-08-31 15:16:57 -0500
commit45e8d978a12da97482c9acf82ea38ad8e64c755a (patch)
tree835fcd05073475a257ac1406f873c77f101f8d62
parent5081e892be565535e1e35f3c31751383be9949e5 (diff)
downloadaur-python-fiat-git.tar.gz
pkgver by git tag; _base; gitignore
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD11
3 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ce2213f9f7c..1c7e4a659d6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-fiat-git
pkgdesc = Generation of arbitrary order Lagrange elements on lines, triangles, and tetrahedra.
- pkgver = 20200113
+ pkgver = 2019.1.0.70.g2f19f48
pkgrel = 1
url = https://bitbucket.org/fenics-project/fiat
arch = any
@@ -15,4 +15,3 @@ pkgbase = python-fiat-git
md5sums = SKIP
pkgname = python-fiat-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..55689ee80ca8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.pkg.tar.xz
+pkg
+src
+*\~
+*.bak
+*.tar.gz
+
+fiat
diff --git a/PKGBUILD b/PKGBUILD
index 90bc27bf79b4..9389ec757d4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
-pkgname=python-fiat-git
+_base=fiat
+pkgname=python-${_base}-git
pkgdesc="Generation of arbitrary order Lagrange elements on lines, triangles, and tetrahedra."
-pkgver=20200113
+pkgver=2019.1.0.70.g2f19f48
pkgrel=1
arch=('any')
url="https://bitbucket.org/fenics-project/fiat"
@@ -11,12 +12,12 @@ groups=('fenics-git')
depends=('python-numpy' 'python-sympy')
makedepends=('python-setuptools' 'git')
options=(!emptydirs)
-source=("fiat::git+https://bitbucket.org/fenics-project/fiat.git")
+source=("fiat::git+${url}.git")
md5sums=('SKIP')
pkgver() {
- cd fiat
- git log --format="%cd" --date=short -1 | sed 's/-//g'
+ cd "${srcdir}/${_base}"
+ git describe --tags --match '*.*' | tr '-' '.'
}
build() {