summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-09-25 22:27:34 -0500
committerLuis Martinez2021-09-25 22:27:34 -0500
commitf24f1552cc23ae6b447390deba054c336be788d9 (patch)
treeb021a81b194c0e91af565a5ac695334dc687e784
parentfd4a922b70c41752f30949e0f9e295dbd4146c23 (diff)
downloadaur-python-flake8-deprecated.tar.gz
package cleanup
-rw-r--r--.SRCINFO13
-rw-r--r--CHANGES.rst66
-rw-r--r--PKGBUILD38
3 files changed, 96 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13cade6fdccb..e377747e2c52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python-flake8-deprecated
- pkgdesc = Warns about deprecated method calls.
+ pkgdesc = Flake8 plugin that warns about deprecated method calls
pkgver = 1.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gforcada/flake8-deprecated
arch = any
- license = GPL-2.0
+ license = GPL2
+ checkdepends = python-pytest
+ makedepends = python-setuptools
depends = flake8
- source = https://github.com/gforcada/flake8-deprecated/archive/1.3.tar.gz
- md5sums = 51bb7161af44baf4ef5f1c610e0343b5
+ source = python-flake8-deprecated-1.3.tar.gz::https://github.com/gforcada/flake8-deprecated/archive/1.3.tar.gz
+ sha256sums = 2cc9c9da5aad69c65a83b0005d887703f4a2e8d9ec7327c0c5d9b7258988caa8
pkgname = python-flake8-deprecated
-
diff --git a/CHANGES.rst b/CHANGES.rst
new file mode 100644
index 000000000000..5ab8698d2215
--- /dev/null
+++ b/CHANGES.rst
@@ -0,0 +1,66 @@
+.. -*- coding: utf-8 -*-
+
+Changelog
+=========
+
+1.3 (2017-10-31)
+----------------
+
+- Fix flake8 errors on this package and enforce them on CI.
+ [alexmuller]
+
+1.2.2.dev0 (2017-10-22)
+-----------------------
+
+- Use the ast module to parse the code and ensure no false positives are found.
+ [alexmuller]
+
+1.2.1 (2017-07-24)
+------------------
+- Fix UnicodeDecodeError if system locale is not UTF-8.
+ [sshishov]
+
+1.2 (2017-05-12)
+----------------
+- added support for sublimetext (stdin/filename handling).
+ [iham]
+
+- Release as universal wheels.
+ [gforcada]
+
+- Only test against Python 2.7, 3.5 and 3.6.
+ It most probably works on earlier versions of 2.x and 3.x but it's pointless to test on them as well.
+ [gforcada]
+
+1.1 (2016-10-26)
+----------------
+- Fix compatibility with flake8 3.
+ [gforcada]
+
+- Require flake8 > 3.0.
+ [gforcada]
+
+1.0 (2016-02-27)
+----------------
+- Warn if using xmlconfig.file, self.loadZCML is the preferred option.
+ [gforcada]
+
+- Avoid false reports by suffixing an opening parenthesis on all methods.
+ [gforcada]
+
+- Add decorators from zope.interface and zope.component.
+ [gforcada]
+
+0.2 (2016-01-20)
+----------------
+- Suggest to use AccessControl and zope.interface decorators.
+ [gforcada]
+
+0.1 (2015-09-17)
+----------------
+- Initial release.
+ [gforcada]
+
+- Create the flake8 plugin per se.
+ [gforcada]
+
diff --git a/PKGBUILD b/PKGBUILD
index ec97740e7d3a..562ec3ddc930 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
-# Maintainer: acxz <akashpatel2008@yahoo.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: acxz <akashpatel2008@yahoo.com>
-pkgname="python-flake8-deprecated"
-_pkgname="flake8-deprecated"
+pkgname=python-flake8-deprecated
+_name="${pkgname#python-}"
pkgver=1.3
-pkgrel=1
-pkgdesc="Warns about deprecated method calls."
+pkgrel=2
+pkgdesc='Flake8 plugin that warns about deprecated method calls'
arch=('any')
-url="https://github.com/gforcada/${_pkgname}"
-license=('GPL-2.0')
+url='https://github.com/gforcada/flake8-deprecated'
+license=('GPL2')
depends=('flake8')
-source=("https://github.com/gforcada/flake8-deprecated/archive/$pkgver.tar.gz")
-md5sums=('51bb7161af44baf4ef5f1c610e0343b5')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest')
+changelog=CHANGES.rst
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('2cc9c9da5aad69c65a83b0005d887703f4a2e8d9ec7327c0c5d9b7258988caa8')
build() {
- cd "${_pkgname}-${pkgver}"
- python setup.py build
+ cd "$_name-$pkgver"
+ python setup.py build
}
-package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+check() {
+ cd "$_name-$pkgver"
+ pytest run_tests.py
+}
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 LICENSE.rst -t "$pkgdir/usr/share/licenses/$pkgname/"
}