summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2020-06-04 17:50:21 +0200
committerneodarz2020-06-04 17:50:21 +0200
commit9b9f992585e99e037cd7cce51de218ff7637c8c2 (patch)
tree5a7afa1c2a9a9b63143342b35c5983a6a211e21b
downloadaur-python-flake8-fixme.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8551806cb4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-flake8-fixme
+ pkgdesc = Check for FIXME, TODO and other temporary developer notes.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/tommilligan/flake8-fixme
+ arch = any
+ license = Apache-2.0
+ depends = python
+ source = https://github.com/tommilligan/flake8-fixme/archive/v1.1.1.tar.gz
+ sha512sums = 99a5c97a57029630ac83e33892eac79f378fb33b1ca291f63ae91e8507c3ccc8a63e0a958ab3e325e1e8c3ea3eb3de1cb6b57dcb0ef47c0ea6a67de057271a30
+
+pkgname = python-flake8-fixme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cad5e4bf81c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+_pkgname=flake8-fixme
+pkgname=python-$_pkgname
+
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Check for FIXME, TODO and other temporary developer notes."
+
+url='https://github.com/tommilligan/flake8-fixme'
+arch=('any')
+license=('Apache-2.0')
+
+depends=('python')
+
+source=("https://github.com/tommilligan/$_pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('99a5c97a57029630ac83e33892eac79f378fb33b1ca291f63ae91e8507c3ccc8a63e0a958ab3e325e1e8c3ea3eb3de1cb6b57dcb0ef47c0ea6a67de057271a30')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+