summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJim Heald2017-03-09 19:32:00 -0800
committerJim Heald2017-03-09 19:32:00 -0800
commit457b80e4c617df09bc809f509a4f97221d7d2a51 (patch)
tree8cb321bd079b88db7d0a0d1ffc2df57ee6adb847
downloadaur-python-flask-oauthlib.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..311bdf10bfa5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-flask-oauthlib
+ pkgdesc = Flask-OAuthlib is an extension to Flask that allows you to interact with remote OAuth enabled applications
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = https://github.com/lepture/flask-oauthlib
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-oauthlib
+ source = https://github.com/lepture/flask-oauthlib/archive/v0.9.3.tar.gz
+ md5sums = 39cf06a3c1ab5550b8e8521604b2b102
+
+pkgname = python-flask-oauthlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc49de8cfc54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jim Heald <james.r.heald@gmail.com>
+
+pkgname=python-flask-oauthlib
+pkgver=0.9.3
+pkgrel=1
+pkgdesc='Flask-OAuthlib is an extension to Flask that allows you to interact with remote OAuth enabled applications'
+arch=(any)
+url='https://github.com/lepture/flask-oauthlib'
+license=('MIT')
+depends=('python' 'python-oauthlib')
+makedepends=('python-setuptools')
+source=("https://github.com/lepture/flask-oauthlib/archive/v${pkgver}.tar.gz")
+md5sums=('39cf06a3c1ab5550b8e8521604b2b102')
+
+build() {
+ cd ${srcdir}/flask-oauthlib-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/flask-oauthlib-${pkgver}
+ python setup.py install --prefix=/usr --root=${pkgdir} --optimize=1
+}