summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Schubert2017-12-01 08:03:26 +0100
committerAdam Schubert2017-12-01 08:03:26 +0100
commit9cf00bdc8cc102403a8ee9a7d15e70f5dacc3eaa (patch)
treeecad48a3630f1068b6d6be905a2f5383da04b8f7
downloadaur-python-flask-redis-helper.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3155e785c34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-flask-redis-helper
+ pkgdesc = Redis support for Flask without breaking PyCharm inspections.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Robpol86/Flask-Redis-Helper
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-redis
+ depends = python-flask
+ source = python-flask-redis-helper-1.0.0.tar.gz::https://codeload.github.com/Robpol86/Flask-Redis-Helper/tar.gz/v1.0.0
+ sha256sums = 7ea88c1e40013cb34d9f62562754f9885c61ded522521dfdb7350831351a5fed
+
+pkgname = python-flask-redis-helper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e428bdb840c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Adam Schubert <adam.schubert@sg1-game.net>
+
+pkgname=python-flask-redis-helper
+pkgver=1.0.0
+pkgdesc="Redis support for Flask without breaking PyCharm inspections."
+pkgrel=1
+arch=('any')
+license=('MIT')
+url='https://github.com/Robpol86/Flask-Redis-Helper'
+source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/Robpol86/Flask-Redis-Helper/tar.gz/v$pkgver)
+sha256sums=('7ea88c1e40013cb34d9f62562754f9885c61ded522521dfdb7350831351a5fed')
+makedepends=('python-setuptools')
+depends=(
+ 'python-redis'
+ 'python-flask'
+)
+
+package() {
+ cd "${srcdir}/Flask-Redis-Helper-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}