summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2024-06-30 18:24:55 -0500
committerHurricanePootis2024-06-30 18:24:55 -0500
commitbae274dd332cd69004ba08be311602a9a3a3552e (patch)
tree10aca573486330ef85ba62acbd3c958abe149153
downloadaur-python-flexcache.tar.gz
Initial commit 0.3
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD29
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04d8f479dbb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-flexcache
+ pkgdesc = A robust and extensible package to cache on disk the result of expensive calculations.
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/hgrecco/flexcache
+ arch = any
+ license = BSD-3-Clause
+ checkdepends = python-pytest-mpl
+ checkdepends = python-pytest-cov
+ checkdepends = python-pytest-subtests
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-setuptools-scm
+ makedepends = python-ruff
+ makedepends = git
+ depends = python
+ depends = python-typing_extensions
+ depends = python-pytest7
+ source = python-flexcache::git+https://github.com/hgrecco/flexcache.git#tag=0.3
+ sha256sums = 8b23a2959b94c77870ca93ff310ae9f21c1d1aec358a518e9c210b88dd51d960
+
+pkgname = python-flexcache
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1447ea82d796
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
+pkgname=python-flexcache
+pkgver=0.3
+pkgrel=1
+pkgdesc="A robust and extensible package to cache on disk the result of expensive calculations."
+arch=(any)
+url="https://github.com/hgrecco/flexcache"
+license=('BSD-3-Clause')
+depends=('python' 'python-typing_extensions' 'python-pytest7')
+makedepends=('python-wheel' 'python-build' 'python-installer' 'python-setuptools' 'python-setuptools-scm' 'python-ruff'
+ 'git')
+checkdepends=('python-pytest-mpl' 'python-pytest-cov' 'python-pytest-subtests')
+source=("$pkgname::git+$url.git#tag=${pkgver}")
+sha256sums=('8b23a2959b94c77870ca93ff310ae9f21c1d1aec358a518e9c210b88dd51d960')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd "$srcdir/$pkgname"
+ pytest
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}