summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYujun Fan2023-10-26 19:42:26 +0800
committerYujun Fan2023-10-26 19:42:26 +0800
commit94014efa11178d0ea3924d1ada0463ee2df4352c (patch)
treee3747f240fdffffab52298186017093c0ecaca7a
downloadaur-python-fpie.tar.gz
useful commit message
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD26
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0390ea62542b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-fpie
+ pkgdesc = A fast poisson image editing algorithm implementation
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/Trinkle23897/Fast-Poisson-Image-Editing
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ optdepends = python-numpy
+ optdepends = gcc
+ optdepends = cmake
+ optdepends = cuda
+ optdepends = python-numba
+ optdepends = python-mpi4py
+ optdepends = python-taichi
+ source = Fast-Poisson-Image-Editing-main.zip::https://github.com/Trinkle23897/Fast-Poisson-Image-Editing/archive/refs/heads/main.zip
+ sha256sums = 130fd9a7a3b59d3401e9d384e342d2a6c3d1b7f595ec16f1b71b1483c29742fd
+
+pkgname = python-fpie
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34dbb3e230c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# maintainer: Yujun Fan <dlutfyj@outlook.com>
+_base=Fast-Poisson-Image-Editing
+pkgname=python-fpie
+pkgver=0.2.4
+pkgrel=1
+pkgdesc="A fast poisson image editing algorithm implementation"
+arch=(any)
+url="https://github.com/Trinkle23897/${_base}"
+license=(MIT)
+depends=(python)
+optdepends=(python-numpy gcc cmake cuda python-numba python-mpi4py python-taichi)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=(${_base}-main.zip::${url}/archive/refs/heads/main.zip)
+sha256sums=('130fd9a7a3b59d3401e9d384e342d2a6c3d1b7f595ec16f1b71b1483c29742fd')
+
+build() {
+ cd ${_base}-main
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+package() {
+ cd ${_base}-main
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}
+