summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorknedl1k2024-06-11 13:43:59 +0200
committerknedl1k2024-06-11 13:43:59 +0200
commitecdadf508378e83c2b443cc60720074553ca0730 (patch)
treec777f46c4a980627c4508c3ac4249e2adeab30e3
parent6598dca9f04c4493a13a97d4fc550242852c7c38 (diff)
downloadaur-ecdadf508378e83c2b443cc60720074553ca0730.tar.gz
bump to 2.5.3 and make license more explicit
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6727ac597775..e5241687b3f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-galsim
pkgdesc = Modular galaxy image simulation toolkit
- pkgver = 2.5.2
+ pkgver = 2.5.3
pkgrel = 1
url = https://github.com/GalSim-developers/GalSim
arch = x86_64
- license = BSD
+ license = BSD-style
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
@@ -17,7 +17,7 @@ pkgbase = python-galsim
depends = fftw
depends = python-coord
depends = python-future
- source = GalSim-2.5.2.tar.gz::https://github.com/GalSim-developers/GalSim/archive/v2.5.2.tar.gz
- sha256sums = e6c04e2c983e241f3cd8a52de289a3ca8bf23c3ebbb692a96fbd27c84b427060
+ source = GalSim-2.5.3.tar.gz::https://github.com/GalSim-developers/GalSim/archive/v2.5.3.tar.gz
+ sha256sums = 22051ba4bf9617eaef6f8279a346419a7cae6f31b152ba53b1c38e3064c6336a
pkgname = python-galsim
diff --git a/PKGBUILD b/PKGBUILD
index f91fd7812954..03488f827ab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,17 @@
# Contributor: GalSim developers team on GitHub
_base=GalSim
pkgname=python-${_base,,}
-pkgver=2.5.2
+pkgver=2.5.3
pkgrel=1
pkgdesc="Modular galaxy image simulation toolkit"
arch=(x86_64)
url="https://github.com/${_base}-developers/${_base}"
-license=('BSD')
+license=('BSD-style')
depends=(python-astropy boost-libs eigen fftw python-coord python-future)
makedepends=(python-build python-installer python-setuptools python-wheel pybind11 python-numpy)
# checkdepends=(python-pytest) # python-timeout python-scipy python-yaml
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha256sums=('e6c04e2c983e241f3cd8a52de289a3ca8bf23c3ebbb692a96fbd27c84b427060')
+sha256sums=('22051ba4bf9617eaef6f8279a346419a7cae6f31b152ba53b1c38e3064c6336a')
build() {
cd ${_base}-${pkgver}
@@ -35,4 +35,4 @@ package() {
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm 644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
-} \ No newline at end of file
+}