summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2019-05-28 10:04:15 -0500
committerXavierCLL2019-05-28 10:04:15 -0500
commit45df81c2644bb65868406404f2c081c168b98df2 (patch)
tree573cd016aceee701cae4087fe1ddde956fd36fba
parent5bbdbeeeed4180a6dbbe02b7bc7206ba7035d8b4 (diff)
downloadaur-python-geopy.tar.gz
Updated to 1.20
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a887a1665e81..9e86d2cde7aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-geopy
- pkgdesc = Geocoding Toolbox for Python 3. Includes geocoder classes for the OpenStreetMap,ESRI ArcGIS,Google,Baidu,Bing,Yahoo,Yandex,IGN France,GeoNames,NaviData,OpenMapQuest,What3Words,OpenCage,SmartyStreets,geocoder.us, and GeocodeFarm geocoder services.
- pkgver = 1.19.0
+ pkgdesc = Geocoding Toolbox for Python 3. Includes geocoder classes for the OpenStreetMap Nominatim, Google Geocoding API (V3), and many other geocoding services
+ pkgver = 1.20.0
pkgrel = 1
url = https://github.com/geopy/geopy
arch = any
@@ -9,10 +9,11 @@ pkgbase = python-geopy
depends = python
depends = python-requests-oauthlib
depends = python-pytz
+ depends = python-geographiclib
provides = python-geopy-git
conflicts = python-geopy-git
- source = https://pypi.python.org/packages/source/g/geopy/geopy-1.19.0.tar.gz
- sha256sums = d2fc0dc79572f5acbcf7e48af1233ac8033079ddb15cae538b9dd03587436de5
+ source = https://pypi.python.org/packages/source/g/geopy/geopy-1.20.0.tar.gz
+ sha256sums = 9419bc90ee6231590c4ae7acf1cf126cefbd0736942da7a6a1436946e80830e2
pkgname = python-geopy
diff --git a/PKGBUILD b/PKGBUILD
index 621c5034e0a9..723a1ef57d54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,28 @@
# Contributer: jyantis <yantis@yantis.net>
pkgname=python-geopy
-pkgver=1.19.0
+pkgver=1.20.0
pkgrel=1
-pkgdesc='Geocoding Toolbox for Python 3. Includes geocoder classes for the OpenStreetMap,ESRI ArcGIS,Google,Baidu,Bing,Yahoo,Yandex,IGN France,GeoNames,NaviData,OpenMapQuest,What3Words,OpenCage,SmartyStreets,geocoder.us, and GeocodeFarm geocoder services.'
+pkgdesc='Geocoding Toolbox for Python 3. Includes geocoder classes for the OpenStreetMap Nominatim, Google Geocoding API (V3), and many other geocoding services'
arch=('any')
url='https://github.com/geopy/geopy'
license=('custom')
depends=('python'
'python-requests-oauthlib'
- 'python-pytz')
+ 'python-pytz'
+ 'python-geographiclib')
source=("https://pypi.python.org/packages/source/g/geopy/geopy-${pkgver}.tar.gz")
-sha256sums=('d2fc0dc79572f5acbcf7e48af1233ac8033079ddb15cae538b9dd03587436de5')
+sha256sums=('9419bc90ee6231590c4ae7acf1cf126cefbd0736942da7a6a1436946e80830e2')
makedepends=('python-setuptools')
provides=('python-geopy-git')
conflicts=('python-geopy-git')
build() {
cd geopy-${pkgver}
-
python setup.py build
}
package() {
cd geopy-${pkgver}
-
python setup.py install --root="${pkgdir}" --optimize=1
}
-
-# vim:set ts=2 sw=2 et: