summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStick2020-04-02 10:38:58 -0400
committerStick2020-04-02 10:39:09 -0400
commit94aef39a94b6cda7869725c5400214a66e2eeb2a (patch)
tree6853687c4386f575e533b3921d64687bfe0ca8eb
parenteeb4ed10fafe8ee2bc65009101a98d1b12c8034e (diff)
downloadaur-python-geventhttpclient-wheels-git.tar.gz
depend on python-gevent-git until >= 1.5a2
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00998d9323ef..de94851e563f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python-geventhttpclient-wheels-git
pkgdesc = A high performance, concurrent http client library for python with gevent
pkgver = 1.3.1dev2.r0.g4d83606
- pkgrel = 4
+ pkgrel = 2
url = https://github.com/locustio/geventhttpclient
arch = x86_64
license = MIT
makedepends = git
makedepends = python-setuptools
depends = python-certifi
+ depends = python-gevent-git
provides = python-geventhttpclient-wheels
conflicts = python-geventhttpclient-wheels
source = python-geventhttpclient-wheels-git::git+https://github.com/locustio/geventhttpclient
diff --git a/PKGBUILD b/PKGBUILD
index 86e25f998239..b66537ba706c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,15 @@
_pkg=python-geventhttpclient-wheels
pkgname="$_pkg-git"
pkgver=1.3.1dev2.r0.g4d83606
-pkgrel=4
+pkgrel=2
pkgdesc="A high performance, concurrent http client library for python with gevent"
arch=('x86_64')
url='https://github.com/locustio/geventhttpclient'
license=('MIT')
-depends=('python-certifi')
+depends=('python-certifi'
+ 'python-gevent-git')
makedepends=('git'
- 'python-setuptools')
+ 'python-setuptools')
provides=("$_pkg")
conflicts=("$_pkg")
source=("$pkgname::git+$url")
@@ -25,10 +26,10 @@ pkgver() {
build() {
cd "$pkgname" || exit
- python setup.py build
+ python setup.py build
}
package() {
cd "$pkgname" || exit
- python setup.py install --skip-build --root="$pkgdir"/ --optimize=1
+ python setup.py install --skip-build --root="$pkgdir"/ --optimize=1
}