summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2022-02-09 14:55:24 +0200
committerAdrian Perez de Castro2022-02-09 14:55:24 +0200
commit8d241da81db7d36a294dcdcc1f0e479a6c3bd971 (patch)
tree4a0c9b7b589fecbbc5e98d77ea6280b77ef243ff
downloadaur-python-gnarl.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--COPYING19
-rw-r--r--PKGBUILD28
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f4876652fac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-gnarl
+ pkgdesc = Lightweight module to define serializable, schema-validated classes
+ pkgver = 0.1.0a4
+ pkgrel = 1
+ url = https://github.com/aperezdc/gnarl
+ arch = any
+ license = custom:MIT
+ makedepends = python-hipack
+ depends = python-schema
+ depends = python-delorean
+ conflicts = python-lasso
+ replaces = python-lasso
+ source = https://pypi.org/packages/source/g/gnarl/gnarl-0.1.0a4.tar.gz
+ source = COPYING
+ b2sums = edc2630ae831b217fc8d4f282fff8bce9c8b286ee0310005ef2e9e594eaf5cf21909e38a016909d16f3d21967d3a2188ec6115dccd2f601e1d6c5c94aac6f574
+ b2sums = a3a63313e1801d623f07b36a74c200e48306c8d6c6f1b83ceb2d5bf2504e1afda996041cf51daa4b04aa5a12aeacaa18a4928d717570590f54845dceef426191
+
+pkgname = python-gnarl
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..151415f5dc93
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!/COPYING
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..fe55b7725208
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,19 @@
+Copyright (c) 2015 Adrián Pérez de Castro
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7651311c8429
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+pkgname=python-gnarl
+_pypiname=${pkgname#python-}
+pkgdesc='Lightweight module to define serializable, schema-validated classes'
+pkgver=0.1.0a4
+pkgrel=1
+arch=(any)
+license=(custom:MIT)
+url=https://github.com/aperezdc/gnarl
+depends=(python-schema python-delorean)
+makedepends=(python-hipack)
+replaces=(python-lasso)
+conflicts=(python-lasso)
+source=("https://pypi.org/packages/source/g/${_pypiname}/${_pypiname}-${pkgver}.tar.gz" COPYING)
+b2sums=('edc2630ae831b217fc8d4f282fff8bce9c8b286ee0310005ef2e9e594eaf5cf21909e38a016909d16f3d21967d3a2188ec6115dccd2f601e1d6c5c94aac6f574'
+ 'a3a63313e1801d623f07b36a74c200e48306c8d6c6f1b83ceb2d5bf2504e1afda996041cf51daa4b04aa5a12aeacaa18a4928d717570590f54845dceef426191')
+
+package () {
+ cd "${_pypiname}-${pkgver}"
+ python setup.py install --optimize=1 --root="${pkgdir}"
+ install -Dm644 "${srcdir}/COPYING" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+
+check () {
+ cd "${_pypiname}-${pkgver}"
+ python setup.py test
+}