summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Tran2024-02-12 01:26:07 -0600
committerMatthew Tran2024-02-12 01:53:20 -0600
commitdefa153a50e6c967465e0653b69658b2a839c37f (patch)
tree37f440e0f808c573036e243bf7077bcfd93294c9
downloadaur-python-gnuplotlib.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab8aeeb92721
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-gnuplotlib
+ pkgdesc = gnuplot for numpy
+ pkgver = 0.41
+ pkgrel = 1
+ url = https://github.com/dkogan/gnuplotlib
+ arch = any
+ license = LGPL-3.0-or-later
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = python-numpysane
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/g/gnuplotlib/gnuplotlib-0.41.tar.gz
+ sha256sums = 4b378dc59c2b334c56613b84b173122aef5c35841e6e46413d6df5ef4e32937c
+
+pkgname = python-gnuplotlib
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50f3d9f0a6d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: 0e4ef622 <0e4ef622 at gmail.com>
+pkgname=python-gnuplotlib
+_name=${pkgname#python-}
+pkgver=0.41
+pkgrel=1
+pkgdesc="gnuplot for numpy"
+arch=('any')
+url="https://github.com/dkogan/gnuplotlib"
+license=('LGPL-3.0-or-later')
+depends=('python-numpy' 'python-numpysane' 'python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('4b378dc59c2b334c56613b84b173122aef5c35841e6e46413d6df5ef4e32937c')
+
+build() {
+ cd $srcdir/$_name-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_name-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}