summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrody2023-12-15 10:05:56 +0100
committerBrody2023-12-15 10:05:56 +0100
commit7e5dc2ab10235b394b0689d33bfaef6caa6ba2e0 (patch)
tree67bee7790c196f925e2a5361a2d9031ce228b718
parent36508dbc8eb451625e0959710a67b5583aed89b7 (diff)
downloadaur-python-google-cloud-core.tar.gz
Update to 2.4.1
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--CHANGELOG.md15
-rw-r--r--PKGBUILD4
4 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29695835cade..5704e67b7d87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-google-cloud-core
pkgdesc = Google Cloud API client core library
- pkgver = 2.3.3
+ pkgver = 2.4.1
pkgrel = 1
url = https://github.com/googleapis/python-cloud-core
changelog = CHANGELOG.md
@@ -14,7 +14,7 @@ pkgbase = python-google-cloud-core
depends = python-google-api-core
depends = python-google-auth
optdepends = python-grpcio: for grpc support
- source = python-google-cloud-core-2.3.3.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-core/google-cloud-core-2.3.3.tar.gz
- b2sums = 1dc72fab3d63577d29d30bbbc6887adc4fda0825f1ece59b384c647ba2df48e4c9d43021f8248eb8328c8f921cda8e1a40f1b85392bf9408bbbe759fad50d9a7
+ source = python-google-cloud-core-2.4.1.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-core/google-cloud-core-2.4.1.tar.gz
+ b2sums = 7c92684114b2977035b93758876ee3c4373c98e80a6db7e6031c75ae1b6276a109e6fcae5a21811a3652b9344b681fa0e38383f0f5d5ca1d6d9a4f1d94b43e8e
pkgname = python-google-cloud-core
diff --git a/.gitignore b/.gitignore
index a5b5e9428445..2bf7d948c2ff 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,8 @@
+## Ignore everything
*
+
+## Except
+!.gitignore
!PKGBUILD
!.SRCINFO
-!.gitignore
!/CHANGELOG.md
diff --git a/CHANGELOG.md b/CHANGELOG.md
index dd90738c2b7c..4c26312ca48d 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,6 +4,21 @@
[1]: https://pypi.org/project/google-cloud-core/#history
+## [2.4.1](https://github.com/googleapis/python-cloud-core/compare/v2.4.0...v2.4.1) (2023-12-07)
+
+
+### Bug Fixes
+
+* Fix regression with `google.cloud._helpers._NOW` ([#266](https://github.com/googleapis/python-cloud-core/issues/266)) ([5310aef](https://github.com/googleapis/python-cloud-core/commit/5310aef5b387aecd87d53acb7beb758dc9acb7e3))
+
+## [2.4.0](https://github.com/googleapis/python-cloud-core/compare/v2.3.3...v2.4.0) (2023-12-07)
+
+
+### Features
+
+* Add support for Python 3.12 ([#256](https://github.com/googleapis/python-cloud-core/issues/256)) ([988a8af](https://github.com/googleapis/python-cloud-core/commit/988a8af3fe5cf2c5f37e08c62b10dcd89e6333c1))
+* Introduce compatibility with native namespace packages ([#260](https://github.com/googleapis/python-cloud-core/issues/260)) ([fd1ef6e](https://github.com/googleapis/python-cloud-core/commit/fd1ef6e03252edca3641cc26ec227a00b4f44221))
+
## [2.3.3](https://github.com/googleapis/python-cloud-core/compare/v2.3.2...v2.3.3) (2023-06-29)
diff --git a/PKGBUILD b/PKGBUILD
index cc218aa818db..a4591286f341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pyname=google-cloud-core
pkgname=python-google-cloud-core
-pkgver=2.3.3
+pkgver=2.4.1
pkgrel=1
pkgdesc='Google Cloud API client core library'
url=https://github.com/googleapis/python-cloud-core
@@ -22,7 +22,7 @@ makedepends=(
optdepends=('python-grpcio: for grpc support')
changelog=CHANGELOG.md
source=(${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz)
-b2sums=(1dc72fab3d63577d29d30bbbc6887adc4fda0825f1ece59b384c647ba2df48e4c9d43021f8248eb8328c8f921cda8e1a40f1b85392bf9408bbbe759fad50d9a7)
+b2sums=(7c92684114b2977035b93758876ee3c4373c98e80a6db7e6031c75ae1b6276a109e6fcae5a21811a3652b9344b681fa0e38383f0f5d5ca1d6d9a4f1d94b43e8e)
build() {
cd ${_pyname}-${pkgver}