summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-12-13 22:32:59 -0600
committerLuis Martinez2021-12-13 22:32:59 -0600
commitb573b37bffa21014522afc45d24a727bc7ed25a0 (patch)
tree75cd529784f1beec19bc2668e14c8e4669bfcf1c
parent28f5bbf3a90a5aff059a3716c0eba5788ba394bc (diff)
downloadaur-b573b37bffa21014522afc45d24a727bc7ed25a0.tar.gz
python 3.10 rebuild
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d9ad5905ede..e4e334a989e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-google-crc32c
pkgdesc = Wraps Google's crc32c library into a Python wrapper
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/googleapis/python-crc32c
arch = x86_64
license = APACHE
diff --git a/PKGBUILD b/PKGBUILD
index 5101fea3f49e..d1ac168ef727 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,8 @@
# Contributor: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=python-google-crc32c
-_name="${pkgname/-google/}"
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Wraps Google's crc32c library into a Python wrapper"
arch=('x86_64')
url="https://github.com/googleapis/python-crc32c"
@@ -17,18 +16,18 @@ sha256sums=('573d5f16a2c8e7cb8eab5e962f2aca6dd4a684178f9803e1c5ca2914bf023afa')
build() {
export CRC32C_INSTALL_PREFIX=/usr
- cd "$_name-$pkgver"
+ cd "python-crc32c-$pkgver"
python setup.py build
}
check() {
- cd "$_name-$pkgver"
+ cd "python-crc32c-$pkgver"
local _ver="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
PYTHONPATH="$PWD/build/lib.linux-$CARCH-$_ver" pytest tests
}
package() {
- cd "$_name-$pkgver"
+ cd "python-crc32c-$pkgver"
PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 README.md SECURITY.md -t "$pkgdir/usr/share/doc/$pkgname/"
}