summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2015-06-13 10:51:14 +0200
committerSébastien Leduc2015-06-13 10:51:14 +0200
commit4dc7f51a44e7ac658cae880f535df1009dc6cd98 (patch)
treef7be9c78a1266f1aaf3e8b9bfbef05ae2e2139b3
downloadaur-python-grapevine.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19bb4f8f9d2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-grapevine
+ pkgdesc = Iterator pipelines for Python
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://jwilk.net/software/python-grapevine
+ arch = any
+ license = MIT
+ depends = python
+ source = https://pypi.python.org/packages/source/g/grapevine/grapevine-1.0+py3k.tar.gz
+ md5sums = 5db4fcac854b4919abe22da8f1eb9cdb
+
+pkgname = python-grapevine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a997d761dc7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: S.Leduc <sebastien@sleduc.fr>
+
+pkgname=python-grapevine
+_realname=grapevine
+pkgver=1.0
+pkgrel=1
+pkgdesc="Iterator pipelines for Python"
+arch=("any")
+url="http://jwilk.net/software/python-grapevine"
+license=('MIT')
+depends=('python')
+source=("https://pypi.python.org/packages/source/g/$_realname/$_realname-$pkgver+py3k.tar.gz")
+md5sums=('5db4fcac854b4919abe22da8f1eb9cdb')
+
+package() {
+ cd "$srcdir/$_realname-$pkgver+py3k"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: