summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Czernia2018-04-20 09:07:39 +0200
committerNils Czernia2018-04-20 09:07:58 +0200
commit932e722cf7a9ff9f4f976a976cb3a83adcd60862 (patch)
treeca4306d092db5a47fe8725dfec39ee243b7ac1b0
downloadaur-python-gsmmodem.tar.gz
Inital commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..445640bbefd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Fr Apr 20 07:07:53 UTC 2018
+pkgbase = python-gsmmodem
+ pkgdesc = python-gsmmodem is a module that allows easy control of a GSM modem attached to the system
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://github.com/faucamp/python-gsmmodem
+ arch = any
+ license = GPL3
+ depends = python
+ source = https://github.com/faucamp/python-gsmmodem/archive/0.9.tar.gz
+ sha256sums = 0ea023791866c0bf35a29686633b97d48e1e7674d0695a69606efb55afe5dd33
+
+pkgname = python-gsmmodem
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2acf4b514783
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Nils Czernia <nils [at] czserver.de>
+
+pkgname=python-gsmmodem
+pkgver=0.9
+pkgrel=1
+pkgdesc="python-gsmmodem is a module that allows easy control of a GSM modem attached to the system"
+url="https://github.com/faucamp/python-gsmmodem"
+license=("GPL3")
+arch=("any")
+source=("https://github.com/faucamp/python-gsmmodem/archive/0.9.tar.gz")
+depends=("python")
+sha256sums=("0ea023791866c0bf35a29686633b97d48e1e7674d0695a69606efb55afe5dd33")
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}"
+ rm -Rf "${pkgdir}/usr/bin"
+}