summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2015-06-08 14:31:47 -0600
committerRich Li2015-06-08 14:31:47 -0600
commit2093b7600152071318f0b0f12b6694358e950340 (patch)
treee077092d4f54ec521ee100fba959485c0db2b080
downloadaur-2093b7600152071318f0b0f12b6694358e950340.tar.gz
Import version 0.2.1 from old AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e0b24653c0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-h5netcdf
+ pkgdesc = Pythonic interface to netCDF4 via h5py
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/shoyer/h5netcdf
+ arch = any
+ license = BSD
+ checkdepends = python-netcdf4
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python-h5py
+ source = https://github.com/shoyer/h5netcdf/archive/v0.2.1.tar.gz
+ md5sums = 4ad00f60c88aae29a6640f030d0ef41e
+
+pkgname = python-h5netcdf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c256653c7a0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: richli <rich at dranek dot com>
+
+pkgname=python-h5netcdf
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Pythonic interface to netCDF4 via h5py"
+arch=('any')
+url="https://github.com/shoyer/h5netcdf"
+license=('BSD')
+depends=('python-h5py')
+makedepends=('python-setuptools')
+checkdepends=('python-netcdf4' 'python-pytest')
+source=(https://github.com/shoyer/h5netcdf/archive/v${pkgver}.tar.gz)
+md5sums=('4ad00f60c88aae29a6640f030d0ef41e')
+
+build() {
+ cd "$srcdir/h5netcdf-${pkgver}"
+ python setup.py build
+}
+
+check() {
+ cd "$srcdir/h5netcdf-${pkgver}"
+ PYTHONPATH="./build/lib" py.test -v
+}
+
+package() {
+ cd "$srcdir/h5netcdf-${pkgver}"
+ python setup.py install --prefix=/usr --root="$pkgdir" --skip-build --optimize 2
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: set et sw=4 ts=4 sts=4: