summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-01-18 16:11:36 +0100
committerPhilipp A2017-01-18 16:13:52 +0100
commit4d4d072f51d9fe458eaac6341b3f739c56a2d44d (patch)
treeeef004b9af06c7f9edd494fe1e3adccaaa7f694d
downloadaur-python-html5lib-9x07.tar.gz
added necessary version
-rw-r--r--.SRCINFO29
-rw-r--r--LICENSE17
-rw-r--r--PKGBUILD34
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42865ba12821
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = python-html5lib-9x07
+ pkgdesc = A Python HTML parser/tokenizer based on the WHATWG HTML5 spec (v0.9999999 as dep for bleach)
+ pkgver = 0.9999999
+ pkgrel = 1
+ url = https://github.com/html5lib
+ arch = any
+ license = MIT
+ checkdepends = python-six
+ checkdepends = python-pytest
+ checkdepends = python-lxml
+ checkdepends = python2-lxml
+ checkdepends = python-mock
+ makedepends = python2
+ makedepends = python
+ makedepends = unzip
+ makedepends = python-webencodings
+ makedepends = python2-webencodings
+ depends = python
+ depends = python-six
+ depends = python-webencodings
+ provides = python-html5lib=0.9999999
+ conflicts = python-html5lib
+ source = python-html5lib-0.9999999.tar.gz::https://github.com/html5lib/html5lib-python/archive/0.9999999.tar.gz
+ source = LICENSE
+ md5sums = 2ca78b1ec5852779bc121a97da6e8d4d
+ md5sums = 838c366f69b72c5df05c96dff79b35f2
+
+pkgname = python-html5lib-9x07
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..89de354795ec
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fb17f5486a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Erol V. Aktay <e.aktay@gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_pkgnm=python-html5lib
+pkgname=python-html5lib-9x07
+pkgdesc="A Python HTML parser/tokenizer based on the WHATWG HTML5 spec (v0.9999999 as dep for bleach)"
+pkgver=0.9999999
+pkgrel=1
+provides=("$_pkgnm=$pkgver")
+conflicts=("$_pkgnm")
+arch=('any')
+url="https://github.com/html5lib"
+license=('MIT')
+depends=('python' 'python-six' 'python-webencodings')
+makedepends=('python2' 'python' 'unzip' 'python-webencodings' 'python2-webencodings')
+checkdepends=('python-six' 'python-pytest' 'python-lxml' 'python2-lxml' 'python-mock')
+source=("$_pkgnm-$pkgver.tar.gz::https://github.com/html5lib/html5lib-python/archive/$pkgver.tar.gz"
+ LICENSE)
+md5sums=('2ca78b1ec5852779bc121a97da6e8d4d'
+ '838c366f69b72c5df05c96dff79b35f2')
+
+package() {
+ cd "$srcdir/html5lib-python-$pkgver"
+
+ python3 setup.py install --root="$pkgdir"
+ install -Dm755 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+check() {
+ cd "$srcdir/html5lib-python-$pkgver/html5lib/tests"
+
+ #nosetests
+}