summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-10-15 23:46:55 -0500
committerLuis Martinez2022-10-15 23:46:55 -0500
commit47e4e48845e353d8ff7a5feb364ead42963b210c (patch)
tree7995f91b3a037a78d9188c1f32aac84cbd66c3e7
parent5909add7af33f01e35ab687d11165eac51bf2d38 (diff)
downloadaur-python-imagededup.tar.gz
update to 0.3.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dee97361836..e3b9865d4b7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-imagededup
pkgdesc = Finding duplicate images made easy
- pkgver = 0.2.4
- pkgrel = 2
+ pkgver = 0.3.0
+ pkgrel = 1
url = https://github.com/idealo/imagededup
arch = x86_64
license = Apache
@@ -18,9 +18,10 @@ pkgbase = python-imagededup
depends = python-pywavelets
depends = python-scikit-learn
depends = python-scipy
- depends = python-tensorflow
+ depends = python-pytorch
+ depends = python-torchvision
depends = python-tqdm
- source = python-imagededup-0.2.4.tar.gz::https://github.com/idealo/imagededup/archive/v0.2.4.tar.gz
- sha256sums = ec8b4d5bd23b50fdf12e3dea5eb680b6852cea13fea3a3ec506098ea91b54c24
+ source = python-imagededup-0.3.0.tar.gz::https://github.com/idealo/imagededup/archive/v0.3.0.tar.gz
+ sha256sums = e16c5402ed19ea2b32b69293c12b0b58f093185cc04d392a18a77e6e984b0dcb
pkgname = python-imagededup
diff --git a/PKGBUILD b/PKGBUILD
index e6edc9299e2c..19c7146d6882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=python-imagededup
_pkg="${pkgname#python-}"
-pkgver=0.2.4
-pkgrel=2
+pkgver=0.3.0
+pkgrel=1
pkgdesc='Finding duplicate images made easy'
arch=('x86_64')
url='https://github.com/idealo/imagededup'
@@ -16,12 +16,13 @@ depends=(
'python-pywavelets'
'python-scikit-learn'
'python-scipy'
- 'python-tensorflow'
+ 'python-pytorch'
+ 'python-torchvision'
'python-tqdm')
makedepends=('cython' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
checkdepends=('python-pytest' 'python-pytest-mock')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('ec8b4d5bd23b50fdf12e3dea5eb680b6852cea13fea3a3ec506098ea91b54c24')
+sha256sums=('e16c5402ed19ea2b32b69293c12b0b58f093185cc04d392a18a77e6e984b0dcb')
build() {
cd "$_pkg-$pkgver"