summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlapicidae2022-05-01 13:02:51 +0200
committerlapicidae2022-05-01 13:02:51 +0200
commit5fbbcc868fbfa3f4ee1b225a98915e28bc8d9683 (patch)
treec612567b512cc6a128d6fc2134194d522708147f
downloadaur-python-irgen.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore61
-rw-r--r--PKGBUILD17
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..307fd957d106
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-irgen
+ pkgdesc = A python module/tool for generating and converting InfraRed commands.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/elupus/irgen
+ arch = any
+ license = MIT
+ depends = python>=3.7
+ source = python-irgen-0.2.0.tar.gz::https://github.com/elupus/irgen/archive/refs/tags/0.2.0.tar.gz
+ md5sums = fd3545116459c7bc7f020c588f78776b
+ sha512sums = 191a59a30584fe0808903aae8912ae83006ccf7b027695f2d283b85e7c3cb606a9881fc8b6af5fc56333fe83bfda0abe101a8666146daeca905d33fc10010639
+
+pkgname = python-irgen
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8f0116b9fc04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,61 @@
+# Windows image file caches
+Thumbs.db
+ehthumbs.db
+
+# Folder config file
+Desktop.ini
+
+# Recycle Bin used on file shares
+$RECYCLE.BIN/
+
+# Windows Installer files
+*.cab
+*.msi
+*.msm
+*.msp
+
+# Windows shortcuts
+*.lnk
+
+# =========================
+# Operating System Files
+# =========================
+
+# Linux
+# =========================
+
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# Kate Swap File
+*.kate-swp
+
+# OSX
+# =========================
+
+.DS_Store
+.AppleDouble
+.LSOverride
+
+# Thumbnails
+._*
+
+# Files that might appear on external disk
+.Spotlight-V100
+.Trashes
+
+# Directories potentially created on remote AFP share
+.AppleDB
+.AppleDesktop
+Network Trash Folder
+Temporary Items
+.apdisk
+.jenkins-external
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9641d6065fa8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Andreas Hemmerle <andreas dot hemmerle at gmail dot com>
+pkgname=python-irgen
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='A python module/tool for generating and converting InfraRed commands.'
+arch=(any)
+license=(MIT)
+url="https://github.com/elupus/irgen"
+depends=("python>=3.7")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/elupus/irgen/archive/refs/tags/$pkgver.tar.gz")
+md5sums=('fd3545116459c7bc7f020c588f78776b')
+sha512sums=('191a59a30584fe0808903aae8912ae83006ccf7b027695f2d283b85e7c3cb606a9881fc8b6af5fc56333fe83bfda0abe101a8666146daeca905d33fc10010639')
+
+package () {
+ cd "$srcdir/irgen-$pkgver"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}