summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2020-09-28 01:05:08 -0300
committerFilipe Nascimento2020-09-28 01:05:08 -0300
commit3893a03ea71358faa2679ce0817a49583946d4d4 (patch)
treedeb28c33a0887d8956b43cf4a22e0bdf180866a9
parentc8e46e9bea48125b9eca3159712827f6c2e67324 (diff)
downloadaur-python-kb-git.tar.gz
upgpkg: python-kb-git 0.1.3.r29.g6a083cf-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 30 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9aec8974369..f3e5b53c3f40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = python-kb-git
pkgdesc = A command line minimalist knowledge base manager
- pkgver = r28.b7b449e
+ pkgver = 0.1.3.r29.g6a083cf
pkgrel = 1
- url = https://github.com/gnebbia/kb.git
+ url = https://github.com/gnebbia/kb
arch = any
license = GPL3
+ checkdepends = python-pytest-cov
makedepends = git
- provides = python-kb-git
- conflicts = python-kb-git
+ depends = python-attrs
+ depends = python-colored
+ depends = python-setuptools
+ depends = python-toml
+ provides = kb
conflicts = python-kb
- conflicts = kb
- source = git+https://github.com/gnebbia/kb.git
+ source = git+https://github.com/gnebbia/kb
md5sums = SKIP
pkgname = python-kb-git
diff --git a/PKGBUILD b/PKGBUILD
index 981677918913..509d9be4b29c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,37 @@
# Maintainer: Giuseppe Nebbione <nebbionegiuseppe at gmail dot com>
+# Maintainer: Filipe Nascimento <flipee at tuta dot io>
pkgname=python-kb-git
-_reponame="kb"
-pkgver=r100.b6b334f
+pkgver=0.1.3.r29.g6a083cf
pkgrel=1
pkgdesc="A command line minimalist knowledge base manager"
arch=(any)
-url="https://github.com/gnebbia/kb.git"
+url="https://github.com/gnebbia/kb"
license=('GPL3')
-depends=()
+depends=('python-attrs' 'python-colored' 'python-setuptools' 'python-toml')
makedepends=('git')
-provides=("python-kb-git")
-conflicts=("python-kb-git" "python-kb" "kb")
+checkdepends=('python-pytest-cov')
+provides=('kb')
+conflicts=('python-kb')
source=("git+$url")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/${_reponame}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd kb
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
- cd "$srcdir/${_reponame}"
- python setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+build() {
+ cd kb
+ python setup.py build
+}
+
+check() {
+ cd kb
+ pytest -v
}
+package() {
+ cd kb
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}