summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2023-08-03 18:18:20 +0800
committertaotieren2023-08-03 18:18:20 +0800
commit2fba210488a8a12591c83bd16fa44ef84ff1e34f (patch)
treebb6e3f062aca2e7b07f6cff95d07519c78e4043f
downloadaur-python-kicad-gitdiff.tar.gz
Update 0.0.4-0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed01c7fe69c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-kicad-gitdiff
+ pkgdesc = Simple visual diff for kicad 7 or higher. one can easily extend this tool to build a diff-er for anything that outputs svg.
+ pkgver = 0.0.4
+ pkgrel = 0
+ url = https://pypi.org/project/kicad-gitdiff
+ arch = any
+ license = Apache-2.0
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ depends = python
+ provides = kicad-gitdiff
+ conflicts = kicad-gitdiff
+ options = !strip
+ source = kicad_gitdiff-0.0.4.tar.gz::https://files.pythonhosted.org/packages/source/k/kicad-gitdiff/kicad_gitdiff-0.0.4.tar.gz
+ sha256sums = e9d709d31dc57cb9e102492f6b5bceeed05affd466aeeaf42af37c6f4cf1946c
+
+pkgname = python-kicad-gitdiff
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9aa30260840d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=python-kicad-gitdiff
+_name=${pkgname#python-}
+pkgver=0.0.4
+pkgrel=0
+epoch=
+pkgdesc="Simple visual diff for kicad 7 or higher. one can easily extend this tool to build a diff-er for anything that outputs svg."
+arch=('any')
+url="https://pypi.org/project/kicad-gitdiff"
+license=(Apache-2.0)
+groups=()
+provides=(${_name})
+conflicts=(${_name})
+depends=(python
+)
+makedepends=(python-build
+ python-installer
+ python-wheel
+ python-setuptools)
+options=('!strip')
+source=("${_name//-/_}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/${_name//-/_}-$pkgver.tar.gz")
+noextract=()
+sha256sums=('e9d709d31dc57cb9e102492f6b5bceeed05affd466aeeaf42af37c6f4cf1946c')
+
+build() {
+ cd "${srcdir}/${_name//-/_}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${srcdir}/${_name//-/_}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}