summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2024-03-26 12:04:54 +0100
committerBlair Bonnett2024-03-26 12:04:54 +0100
commit61989e20693da983a7d104b4a8b24b830c0fd4af (patch)
tree78379e4c0129d42592a16089996eeaee4d38ab2d
parenteb3d0f59712adf7a62e85d787a4a671a7df5bba0 (diff)
downloadaur-python-lazrs.tar.gz
Update to 0.6.0; sources now available on PyPI.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02e1e24aded6..3213049dc65f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python-lazrs
pkgdesc = Python bindings for laz-rs (LAZ compression)
- pkgver = 0.5.3
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/laz-rs/laz-rs-python
arch = x86_64
license = MIT
- makedepends = git
makedepends = python-build
makedepends = python-installer
makedepends = python-maturin
depends = gcc-libs
depends = glibc
depends = python
- source = git+https://github.com/laz-rs/laz-rs-python.git#tag=0.5.3
- sha256sums = SKIP
+ source = https://files.pythonhosted.org/packages/source/l/lazrs/lazrs-0.6.0.tar.gz
+ sha256sums = 6d7a2f5427542dc38d616e2470254dde29f9ba604b3fd00826160c6977c6b4d9
pkgname = python-lazrs
diff --git a/PKGBUILD b/PKGBUILD
index 8909ad7c066e..8fec635d64a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,37 @@
pkgname=python-lazrs
pkgdesc="Python bindings for laz-rs (LAZ compression)"
-pkgver=0.5.3
+pkgver=0.6.0
pkgrel=1
url='https://github.com/laz-rs/laz-rs-python'
arch=('x86_64')
license=('MIT')
depends=('gcc-libs' 'glibc' 'python')
-makedepends=('git' 'python-build' 'python-installer' 'python-maturin')
+makedepends=('python-build' 'python-installer' 'python-maturin')
_pypi=lazrs
source=(
- "git+https://github.com/laz-rs/laz-rs-python.git#tag=$pkgver"
+ "https://files.pythonhosted.org/packages/source/${_pypi::1}/$_pypi/$_pypi-$pkgver.tar.gz"
)
sha256sums=(
- 'SKIP'
+ '6d7a2f5427542dc38d616e2470254dde29f9ba604b3fd00826160c6977c6b4d9'
)
build() {
- cd laz-rs-python
+ cd "$_pypi-$pkgver"
python -m build --no-isolation --wheel
}
check() {
- cd laz-rs-python
+ cd "$_pypi-$pkgver"
python -m venv --system-site-packages test-env
test-env/bin/python -m installer "dist/$_pypi-$pkgver-"*.whl
test-env/bin/python -c 'import lazrs'
}
package() {
- cd laz-rs-python
+ cd "$_pypi-$pkgver"
python -m installer --destdir="$pkgdir" "dist/$_pypi-$pkgver-"*.whl
install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
}