summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchris2021-02-17 18:17:58 +0100
committerchris2021-02-17 18:17:58 +0100
commit486e8317429fa6410d3b90b0abd680bd8e74a9e2 (patch)
tree7fce9ae2e6499e238738c1f9e9387b656c08cf04
downloadaur-python-libreasr.tar.gz
+ try first build
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD47
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa6ef7d904d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-libreasr
+ pkgdesc = LibreASR: An On-Premises, Streaming Speech Recognition System
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/iceychris/LibreASR
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = make
+ source = https://github.com/iceychris/LibreASR/archive/dev.zip
+ md5sums = SKIP
+
+pkgname = python-libreasr
+ depends = python>=3.7
+ optdepends = python-matplotlib
+ optdepends = python-scipy
+ optdepends = python-scikit-image
+ optdepends = python-stsci.imagestats
+ optdepends = python-acstools-doc: Documentation for Python ACS Tools
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c952aa2d62de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: iceychris <none>
+pkgbase=python-libreasr
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}")
+#"python-${_pyname}-doc")
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="LibreASR: An On-Premises, Streaming Speech Recognition System"
+arch=('i686' 'x86_64')
+url="https://github.com/iceychris/LibreASR"
+license=('MIT')
+makedepends=('make')
+#'python-pandas' 'python-astropy' 'python-beautifulsoup4' 'python-sphinx-automodapi' 'python-sphinx_rtd_theme' 'python-matplotlib')
+# checkdepends=('python-pytest-astropy-header'
+# 'python-astropy'
+# 'python-beautifulsoup4'
+# 'python-requests'
+# 'python-ci_watson'
+# 'python-yaml'
+# 'python-matplotlib')
+# https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz
+source=("https://github.com/iceychris/LibreASR/archive/dev.zip")
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+ python setup.py build
+}
+
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+ make tests
+}
+
+package() {
+ depends=('python>=3.7')
+ optdepends=('python-matplotlib'
+ 'python-scipy'
+ 'python-scikit-image'
+ 'python-stsci.imagestats'
+ 'python-acstools-doc: Documentation for Python ACS Tools')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ # install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/LICENSE.md"
+ # install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.rst
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}