summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStick2020-06-19 10:56:43 -0400
committerStick2020-06-19 10:56:43 -0400
commit0a287a1c22522f589dd8254395775af74be940bb (patch)
tree82b456dba73007ba0783af4de168bb14bd8931b6
parent4cb189e835c62eef7845d3cac1f0ed3f3f600a3f (diff)
downloadaur-python-locust-git.tar.gz
update deps for 1.0.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2d0ceef9d1a..9db9b880e8de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
pkgbase = python-locust-git
pkgdesc = Scalable user load testing tool written in Python
- pkgver = 0.14.5.r83.g34cb6d1
- pkgrel = 2
+ pkgver = 1.0.3.r25.g5ea0342
+ pkgrel = 1
url = https://github.com/locustio/locust
arch = any
license = MIT
makedepends = git
makedepends = python-setuptools
- depends = python-configargparse
- depends = python-flask
depends = python-gevent
- depends = python-geventhttpclient-wheels
+ depends = python-flask
+ depends = python-requests
depends = python-msgpack
- depends = python-psutil
depends = python-pyzmq
- depends = python-requests
- depends = python-six
+ depends = python-geventhttpclient
+ depends = python-configargparse
+ depends = python-psutil
+ depends = python-flask-basicauth
provides = python-locust
conflicts = python-locust
source = python-locust-git::git+https://github.com/locustio/locust
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = python-locust-git
diff --git a/PKGBUILD b/PKGBUILD
index 9a514aadfa9e..b27de8146b9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,27 @@
_pkg=locust
pkgname="python-$_pkg-git"
-pkgver=0.14.5.r83.g34cb6d1
-pkgrel=2
+pkgver=1.0.3.r25.g5ea0342
+pkgrel=1
pkgdesc="Scalable user load testing tool written in Python"
arch=('any')
url="https://github.com/locustio/$_pkg"
license=('MIT')
-depends=('python-configargparse'
+depends=('python-gevent'
'python-flask'
- 'python-gevent'
- 'python-geventhttpclient-wheels'
+ 'python-requests'
'python-msgpack'
- 'python-psutil'
'python-pyzmq'
- 'python-requests'
- 'python-six')
+ 'python-geventhttpclient'
+ 'python-configargparse'
+ 'python-psutil'
+ 'python-flask-basicauth')
makedepends=('git'
'python-setuptools')
provides=("python-$_pkg")
conflicts=("python-$_pkg")
source=("$pkgname::git+$url")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname" || exit
@@ -34,8 +34,7 @@ pkgver() {
build() {
cd "$pkgname" || exit
- sed -i 's/msgpack-python/msgpack/' setup.py
- sed -i 's/ "\([[:alpha:]-]*\).=.*"/ "\1"/' setup.py
+ # sed -i 's/ "\([[:alpha:]-]*\).=.*"/ "\1"/' setup.py
python setup.py build
}