summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2020-11-01 12:44:22 +0100
committerGrey Christoforo2020-11-01 12:44:22 +0100
commit1331bd7976a3f14d14a6c8204d082d9d42beaa34 (patch)
tree75450748c020527e9d4ef261c33c03ca545d1242
downloadaur-python-macs.tar.gz
move macs to python3
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edce77b8f76e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-macs
+ pkgdesc = MACS -- Model-based Analysis of ChIP-Seq
+ pkgver = 2.2.7.1
+ pkgrel = 1
+ url = https://macs3-project.github.io/MACS/
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-numpy
+ conflicts = python2-macs2
+ replaces = python2-macs2
+ source = https://github.com/macs3-project/MACS/archive/v2.2.7.1.tar.gz
+ md5sums = 3b669e6b847e5d2edd9b9ab4b58edae9
+
+pkgname = python-macs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..207cdf2b7f96
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c6e692bf966
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Grey Christoforo <grey at christoforo dot net>
+
+pkgname=python-macs
+pkgver=2.2.7.1
+pkgrel=1
+pkgdesc="MACS -- Model-based Analysis of ChIP-Seq"
+arch=('x86_64')
+url="https://macs3-project.github.io/MACS/"
+license=('BSD')
+conflicts=('python2-macs2')
+replaces=('python2-macs2')
+depends=('python-numpy')
+makedepends=('python-setuptools')
+source=("https://github.com/macs3-project/MACS/archive/v${pkgver}.tar.gz")
+md5sums=('3b669e6b847e5d2edd9b9ab4b58edae9')
+
+prepare() {
+ cd "MACS-${pkgver}"
+
+ # don't call pip
+ curl https://github.com/greyltc/MACS/commit/c39b55d8dfa6d57cb4d11e37b7f0947f7629702e.patch | patch -p1
+}
+
+build() {
+ cd "MACS-${pkgver}"
+ python setup.py build
+}
+
+package(){
+ cd "MACS-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}