summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2023-05-07 13:41:01 +0200
committerMarco Rubin2023-05-07 13:41:01 +0200
commitb38aab3ca8f3b916657236c678ed17dd3eed8cda (patch)
tree74c4bdbfb3ac0befa7703c47efc4e5a5ba0d3dac
parent90ff18620caf5da1e1a565b7940811a614b5ed6d (diff)
downloadaur-python-matlabengine.tar.gz
9.14.3
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1943e64bd13c..66388fdf16d1 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,9 +7,11 @@ pkgbase = python-matlabengine
license = MIT
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools>=42
makedepends = python-wheel
- depends = matlab
- depends = python
+ depends = matlab>=9.14
+ depends = python>=3.8
+ depends = python<3.11
source = https://github.com/mathworks/matlab-engine-for-python/archive/refs/tags/9.14.3.tar.gz
b2sums = 491f56fad8007a943b33b9daebcba4a61ca007d93151eaa65394439d4ca9ef1745d4b28e5a41b6dea858da36ecbdaba07b1a6ac0005ebc6373abdc06f3f7fa7e
diff --git a/PKGBUILD b/PKGBUILD
index a681662cc2bb..251a689cbbf7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,14 @@ pkgdesc='A module to call MATLAB from Python'
arch=(x86_64)
url='https://github.com/mathworks/matlab-engine-for-python'
license=('MIT')
-depends=(matlab python)
-makedepends=(python-build python-installer python-wheel)
+depends=('matlab>=9.14' 'python>=3.8' 'python<3.11')
+makedepends=(python-build python-installer 'python-setuptools>=42' python-wheel)
source=("$url/archive/refs/tags/$pkgver.tar.gz")
b2sums=('491f56fad8007a943b33b9daebcba4a61ca007d93151eaa65394439d4ca9ef1745d4b28e5a41b6dea858da36ecbdaba07b1a6ac0005ebc6373abdc06f3f7fa7e')
build() {
cd $_name-$pkgver
- _malabroot=$(matlab -nodisplay -nojvm -batch "matlabroot" | grep -Eo "/.*[^']")
+ _matlabroot=$(matlab -nodisplay -nojvm -batch "matlabroot" | grep -Eo "/.*[^']")
export LD_LIBRARY_PATH=$_matlabroot/bin/glnxa64
python -m build --wheel --no-isolation
}