summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Cappelletti2021-04-02 22:27:23 +0200
committerLorenzo Cappelletti2021-04-02 22:27:23 +0200
commit8a7e3e12fc44f9b4583af609b57d7764ed79c569 (patch)
tree04d07e06e81fb7166e19eac9190179780b2b5b0d
parent8a4d4532877b49331675073c7cf776a6737bf42c (diff)
downloadaur-python-mbed-icetea.tar.gz
Drop support to Python2
A few dependency packages are no longer available for Python2 (notably pyserial).
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD78
2 files changed, 29 insertions, 75 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca3f8fa76855..28bde850a652 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,11 @@
pkgbase = python-mbed-icetea
pkgdesc = mbed test framework
pkgver = 2.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ARMmbed/icetea
arch = any
license = Apache
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = python-mbed-icetea-2.0.1.tar.gz::https://github.com/ARMmbed/icetea/archive/v2.0.1.tar.gz
- sha256sums = 5c31d2fc60b543f82c59545218a78795a00a6d09412e0c6e8e0e528df398dadb
-
-pkgname = python-mbed-icetea
depends = python
depends = python-prettytable
depends = python-requests
@@ -27,21 +22,8 @@ pkgname = python-mbed-icetea
optdepends = python-coloredlogs: decorate your console outputs with all kind of colors
optdepends = python-psutil
optdepends = python-pyshark: sniffer integration
+ source = python-mbed-icetea-2.0.1.tar.gz::https://github.com/ARMmbed/icetea/archive/v2.0.1.tar.gz
+ sha256sums = 5c31d2fc60b543f82c59545218a78795a00a6d09412e0c6e8e0e528df398dadb
-pkgname = python2-mbed-icetea
- depends = python2
- depends = python2-prettytable
- depends = python2-requests
- depends = python2-yattag
- depends = python2-pyserial
- depends = python2-jsonmerge
- depends = python2-jsonschema
- depends = python2-mbed-ls
- depends = python2-semver
- depends = python2-mbed-flasher
- depends = python2-six
- depends = python2-pydash
- depends = python2-transitions
- optdepends = python2-coloredlogs: decorate your console outputs with all kind of colors
- optdepends = python2-psutil
+pkgname = python-mbed-icetea
diff --git a/PKGBUILD b/PKGBUILD
index cd64e5a1f384..ee3736cc4cbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,68 +1,40 @@
# Maintainer: Lorenzo Cappelletti <lorenzo.cappelletti gmail.com>
-pkgbase=python-mbed-icetea
-pkgname=('python-mbed-icetea' 'python2-mbed-icetea')
+pkgname=python-mbed-icetea
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc='mbed test framework'
arch=('any')
url='https://github.com/ARMmbed/icetea'
license=('Apache')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("${pkgbase}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+makedepends=('python-setuptools')
+depends=(
+ 'python'
+ 'python-prettytable'
+ 'python-requests'
+ 'python-yattag'
+ 'python-pyserial'
+ 'python-jsonmerge'
+ 'python-jsonschema'
+ 'python-mbed-ls'
+ 'python-semver'
+ 'python-mbed-flasher'
+ 'python-six'
+ 'python-pydash'
+ 'python-transitions'
+)
+optdepends=(
+ 'python-coloredlogs: decorate your console outputs with all kind of colors'
+ 'python-psutil'
+ 'python-pyshark: sniffer integration'
+)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha256sums=('5c31d2fc60b543f82c59545218a78795a00a6d09412e0c6e8e0e528df398dadb')
-package_python-mbed-icetea() {
- depends=(
- 'python'
- 'python-prettytable'
- 'python-requests'
- 'python-yattag'
- 'python-pyserial'
- 'python-jsonmerge'
- 'python-jsonschema'
- 'python-mbed-ls'
- 'python-semver'
- 'python-mbed-flasher'
- 'python-six'
- 'python-pydash'
- 'python-transitions'
- )
- optdepends=(
- 'python-coloredlogs: decorate your console outputs with all kind of colors'
- 'python-psutil'
- 'python-pyshark: sniffer integration'
- )
-
+package() {
cd "icetea-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
python setup.py clean --all
}
-package_python2-mbed-icetea() {
- depends=(
- 'python2'
- 'python2-prettytable'
- 'python2-requests'
- 'python2-yattag'
- 'python2-pyserial'
- 'python2-jsonmerge'
- 'python2-jsonschema'
- 'python2-mbed-ls'
- 'python2-semver'
- 'python2-mbed-flasher'
- 'python2-six'
- 'python2-pydash'
- 'python2-transitions'
- )
- optdepends=(
- 'python2-coloredlogs: decorate your console outputs with all kind of colors'
- 'python2-psutil'
- )
-
- cd "icetea-${pkgver}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- python2 setup.py clean --all
-}
-
# vim:set ts=2 sw=2 et: