summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Pronko2021-01-25 14:43:19 +0300
committerPlaton Pronko2021-01-25 14:43:19 +0300
commit3ff4ec5fbc3e747a91465582f9601f0f471fd382 (patch)
treec748191c522b161ef70fcd3045c53b00beb2184e
downloadaur-python-meteocalc.tar.gz
release version 1.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d1003652b2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-meteocalc
+ pkgdesc = Several functions for calculation of meteorological variables: dew point, heat index, wind chill, feels like temperature.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/malexer/meteocalc
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ source = https://github.com/malexer/meteocalc/archive/1.1.0.tar.gz
+ sha256sums = 3dae55e9b8380af04e3eadd6fa26d81ecb6250562c4a862b9a31801548e43ccb
+
+pkgname = python-meteocalc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c66f234b222c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.tar.gz
+*.tar.xz
+*.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dab647b66471
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Platon Pronko <platon7pronko@gmail.com>
+
+pkgname='python-meteocalc'
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Several functions for calculation of meteorological variables: dew point, heat index, wind chill, feels like temperature."
+arch=("any")
+url="https://github.com/malexer/meteocalc"
+license=("MIT")
+makedepends=("python-setuptools")
+
+source=("https://github.com/malexer/meteocalc/archive/${pkgver}.tar.gz")
+sha256sums=('3dae55e9b8380af04e3eadd6fa26d81ecb6250562c4a862b9a31801548e43ccb')
+
+prepare() {
+ cd "${srcdir}/meteocalc-${pkgver}"
+}
+
+package() {
+ cd "${srcdir}/meteocalc-${pkgver}"
+ python setup.py install --root=${pkgdir}
+}