summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Czernia2019-11-26 11:37:02 +0100
committerNils Czernia2019-11-26 11:37:02 +0100
commite1a1dc20141841fa389f06fc4e02aa4afcd865e0 (patch)
tree82e7179502e26e4f85c5b9b1b26370f63d41f66f
downloadaur-python-miflora-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb1963680d7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-miflora-git
+ pkgdesc = Library for Xiaomi Mi plant sensor
+ pkgver = ebda66d
+ pkgrel = 1
+ url = https://github.com/open-homeautomation/miflora
+ arch = any
+ license = MIT
+ depends = python
+ conflicts = python-miflora
+ source = miflora::git+https://github.com/open-homeautomation/miflora.git
+ sha512sums = SKIP
+
+pkgname = python-miflora-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67b74a07e860
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Nils Czernia <nils[at]czserver.de>
+
+pkgname=python-miflora-git
+_pkgname=miflora
+pkgver=ebda66d
+pkgrel=1
+pkgdesc="Library for Xiaomi Mi plant sensor"
+url="https://github.com/open-homeautomation/miflora"
+arch=("any")
+license=("MIT")
+depends=("python")
+source=("${_pkgname}::git+https://github.com/open-homeautomation/miflora.git")
+conflicts=("python-miflora")
+sha512sums=("SKIP")
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --always | sed -e 's|-|.|g'
+}
+
+build() {
+ cd "${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}"
+ python setup.py install --skip-build -O1 --root="${pkgdir}"
+
+ rm -Rf ${pkgdir}/usr/lib/*/site-packages/test/
+}
+
+# vim: ts=2 sw=2 et: