summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqaz2020-05-28 16:32:30 +0800
committerqaz2020-05-28 16:32:30 +0800
commit4823c689ef05a4bd8f26f1983ed1ecf730aee079 (patch)
tree4fca5bd877c77ba7cff32a903e049a5882970646
downloadaur-python-mingus.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da5abb6f4925
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-mingus
+ pkgdesc = A package for Python used by programmers, musicians, composers and researchers to make and investigate music.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/bspaans/python-mingus
+ arch = any
+ license = GPL
+ depends = python-six
+ optdepends = lilypond
+ optdepends = fluidsynth
+ source = https://github.com/bspaans/python-mingus/archive/0.6.0.tar.gz
+ md5sums = c02c316ffbea978257f5cc6a367e8f1e
+
+pkgname = python-mingus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49fd52e5bc7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mark Coolen <mark dot coolen at gmail dot com>
+# Contributer: fkxxyz <fkxxyz@163.com>
+
+pkgname=python-mingus
+pkgver=0.6.0
+_python_dir_ver=3.8
+pkgrel=1
+pkgdesc="A package for Python used by programmers, musicians, composers and researchers
+to make and investigate music."
+arch=('any')
+url="https://github.com/bspaans/python-mingus"
+license=('GPL')
+depends=('python-six')
+optdepends=('lilypond' 'fluidsynth')
+source=("https://github.com/bspaans/python-mingus/archive/${pkgver}.tar.gz")
+md5sums=('c02c316ffbea978257f5cc6a367e8f1e')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$pkgdir/usr"
+ mv mingus_examples lib/python${_python_dir_ver}/site-packages/mingus/examples
+}