summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButui Hu2021-12-30 20:54:34 +0800
committerButui Hu2021-12-30 20:54:34 +0800
commite62d55ad8311154c15e36732d0a5deb92e8366fa (patch)
tree55085689b2c3c78dcc55bea26f948393939c5d6e
downloadaur-python-ml-collections.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ac5b0775344
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-ml-collections
+ pkgdesc = A library of Python Collections designed for ML use cases
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/google/ml_collections
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = absl-py
+ depends = python-contextlib2
+ depends = python-six
+ depends = python-yaml
+ source = ml_collections-0.1.1.tar.gz::https://github.com/google/ml_collections/archive/refs/tags/v0.1.1.tar.gz
+ sha512sums = 4ee02a53ab597acb2a239d0764412ad1f9a9959b8ab486ed18fc96837013a5a475bb73c1ee04419852af5f5ecdb7b4a33db36e4ec431d549c9fa2bc5934676d8
+
+pkgname = python-ml-collections
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12b54d5571aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Butui Hu <hot123tea123@gmail.com>
+
+_pkgname=ml_collections
+pkgname=python-ml-collections
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='A library of Python Collections designed for ML use cases'
+arch=('any')
+url='https://github.com/google/ml_collections'
+license=('Apache')
+depends=(
+ absl-py
+ python-contextlib2
+ python-six
+ python-yaml
+)
+makedepends=(
+ python-setuptools
+)
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/google/ml_collections/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('4ee02a53ab597acb2a239d0764412ad1f9a9959b8ab486ed18fc96837013a5a475bb73c1ee04419852af5f5ecdb7b4a33db36e4ec431d549c9fa2bc5934676d8')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+# vim:set ts=2 sw=2 et: