summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2024-03-15 12:18:13 +0800
committerlilac2024-03-15 12:18:13 +0800
commit4300d5ced0c5092616dd61b6b8c0c23aca71097f (patch)
tree9e55bbb6c49da9be7ec0027cff4815c06a33b5ab
parent7bb4e3b151cc93e96efc4e794cc9bcdcf9ebc203 (diff)
downloadaur-python-mmpycocotools.tar.gz
[lilac] updated to 12.0.3-6
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bcf2f9bfe06..ba084ad77ecb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = python-mmpycocotools
pkgdesc = Official APIs for the MS-COCO dataset (openmm lab fork)
pkgver = 12.0.3
- pkgrel = 5
+ pkgrel = 6
url = https://pypi.org/project/mmpycocotools
arch = x86_64
- license = BSD
+ license = BSD-2-Clause
makedepends = cython
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
+ depends = glibc
depends = python-matplotlib
depends = python-numpy
provides = python-pycocotools
diff --git a/PKGBUILD b/PKGBUILD
index 6b3bfa5b91af..1a007e467b6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgname=python-mmpycocotools
_pkgname=mmpycocotools
pkgver=12.0.3
-pkgrel=5
+pkgrel=6
pkgdesc='Official APIs for the MS-COCO dataset (openmm lab fork)'
arch=(x86_64)
url='https://pypi.org/project/mmpycocotools'
-license=(BSD)
+license=('BSD-2-Clause')
depends=(
+ glibc
python-matplotlib
python-numpy
)
@@ -32,6 +33,8 @@ sha512sums=('8eb699757531edbb689f28895d0613d1f7bea88a6a6fadb4d4d30021ba7af8bd9e7
prepare() {
# fix https://github.com/open-mmlab/cocoapi/issues/29
sed -i "s,np.float,float,g" "${_pkgname}-${pkgver}/pycocotools/cocoeval.py"
+ # fix building with cython >= 3
+ sed -i "/distutils/d" "${_pkgname}-${pkgver}/pycocotools/_mask.pyx"
}
build() {