summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2023-11-19 17:20:45 +0100
committerMuflone2023-11-19 17:20:45 +0100
commitdaa9759333a0b9c430e71817d1d98d5e41b7503f (patch)
treecbb6c3e3ea7ae036b2bcfe83cbdb7facd3ad61f9
parent912d05f3a495c9c08a7d90f4ca5fd0b015d1ad11 (diff)
downloadaur-python-mumailer.tar.gz
Updated package python-mumailer 0.5.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2850a22327c..dddb34db3395 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-mumailer
pkgdesc = Simple mailer agent using SMTP
- pkgver = 0.4.4
+ pkgver = 0.5.0
pkgrel = 1
url = http://www.muflone.com/mumailer
arch = any
@@ -10,9 +10,9 @@ pkgbase = python-mumailer
makedepends = python-setuptools
makedepends = python-wheel
depends = python-yaml
- depends = python>=3.11
- source = mumailer-0.4.4.tar.gz::https://github.com/muflone/mumailer/archive/0.4.4.tar.gz
- sha256sums = 8c443e807efea01b987e7233cbe16459834e999007d27ad07ebecd357eba85fe
+ depends = python
+ source = mumailer-0.5.0.tar.gz::https://github.com/muflone/mumailer/archive/0.5.0.tar.gz
+ sha256sums = 2dc71fe86dffefd404a9ec0d1070f63fd601595e4a66eaaf78bc79cf68f53231
pkgname = python-mumailer
pkgdesc = Python package to easily send email messages using SMTP
diff --git a/PKGBUILD b/PKGBUILD
index 9739804a5030..93bce36498f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_pkgname=mumailer
pkgname=("python-mumailer" "mumailer")
-pkgver=0.4.4
+pkgver=0.5.0
pkgrel=1
pkgdesc="Simple mailer agent using SMTP"
url="http://www.muflone.com/mumailer"
arch=('any')
license=('GPL3')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-depends=('python-yaml' 'python>=3.11')
+depends=('python-yaml' 'python')
source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/muflone/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('8c443e807efea01b987e7233cbe16459834e999007d27ad07ebecd357eba85fe')
+sha256sums=('2dc71fe86dffefd404a9ec0d1070f63fd601595e4a66eaaf78bc79cf68f53231')
build() {
cd "${_pkgname}-${pkgver}"
@@ -23,11 +23,6 @@ package_python-mumailer() {
cd "${_pkgname}-${pkgver}"
python -m installer --destdir="${pkgdir}" dist/*.whl
- for _file in "${pkgdir}/usr/lib/python3.11/site-packages/mumailer/samples"/*.py
- do
- chmod +x "${_file}"
- sed -i '1i#!/usr/bin/python' "${_file}"
- done
rm "${pkgdir}/usr/bin/mumailer"
rmdir "${pkgdir}/usr/bin"
install -d "${pkgdir}/usr/share/doc/${pkgname}"
@@ -42,3 +37,4 @@ package_mumailer() {
python -m installer --destdir="build" dist/*.whl
install -m 755 -D "build/usr/bin/mumailer" "${pkgdir}/usr/bin/${pkgname}"
}
+