summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Forencich2020-07-24 01:10:54 -0700
committerAlex Forencich2020-07-24 01:10:54 -0700
commit4bbab6f2ce8912273ee2b9fb0685ef2cac659c99 (patch)
treee7fe5e9c1636d56f5302455b8edb113c8b66e82e
parent6e8049460f28c946378b0366b12f6ea3ab167c62 (diff)
downloadaur-python-myhdl-git.tar.gz
New revision, drop python 2 split
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 11 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59f8391ddb30..03f38941ea07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-myhdl-git
pkgdesc = a Python-Based Hardware Description Language
- pkgver = 0.10.r15.ge185577
+ pkgver = 0.11.r14.ga4708fa
pkgrel = 1
url = http://www.myhdl.org/
arch = any
@@ -8,19 +8,12 @@ pkgbase = python-myhdl-git
makedepends = git
makedepends = python-sphinx
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = myhdl::git+https://github.com/myhdl/myhdl.git
- md5sums = SKIP
-
-pkgname = python-myhdl-git
depends = python
depends = iverilog
provides = python-myhdl
conflicts = python-myhdl
+ source = myhdl::git+https://github.com/myhdl/myhdl.git
+ md5sums = SKIP
-pkgname = python2-myhdl-git
- depends = python2
- depends = iverilog
- provides = python2-myhdl
- conflicts = python2-myhdl
+pkgname = python-myhdl-git
diff --git a/PKGBUILD b/PKGBUILD
index 27d0cf53ee7d..177882bf3a88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,15 @@
# Maintainer: Alex Forencich <alex@alexforencich.com>
-pkgname=(python-myhdl-git python2-myhdl-git)
-pkgver=0.10.r15.ge185577
+pkgname=python-myhdl-git
+pkgver=0.11.r14.ga4708fa
pkgrel=1
pkgdesc="a Python-Based Hardware Description Language"
arch=('any')
url="http://www.myhdl.org/"
license=('LGPL')
-makedepends=('git' 'python-sphinx' 'python-setuptools' 'python2-setuptools')
+makedepends=('git' 'python-sphinx' 'python-setuptools')
+depends=('python' 'iverilog')
+provides=('python-myhdl')
+conflicts=('python-myhdl')
_gitroot='https://github.com/myhdl/myhdl.git'
_gitname='myhdl'
@@ -29,11 +32,7 @@ build() {
make
}
-package_python-myhdl-git() {
- depends=('python' 'iverilog')
- provides=('python-myhdl')
- conflicts=('python-myhdl')
-
+package() {
cd "$srcdir/$_gitname"
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
@@ -42,16 +41,3 @@ package_python-myhdl-git() {
install -m 0755 -D ./cosimulation/icarus/myhdl.vpi $pkgdir/usr/lib/ivl/myhdl.vpi
}
-package_python2-myhdl-git() {
- depends=('python2' 'iverilog')
- provides=('python2-myhdl')
- conflicts=('python2-myhdl')
-
- cd "$srcdir/$_gitname"
- python2 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
-
- rm -rf $pkgdir/usr/share/myhdl
-
- install -m 0644 -D ./LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE.txt
-}
-